Author Topic: XML wordwrap ALWAYS wordwraps  (Read 5400 times)

skywise

  • Senior Community Member
  • Posts: 331
  • Hero Points: 10
XML wordwrap ALWAYS wordwraps
« on: September 09, 2008, 10:47:28 pm »
Visual Slickedit 13.0.2 - Windows XP

Was trying to debug a possible XML parsing issue when I discovered that SlickEdit always wants to wrap my XML file at 74 characters out. Okay, says I, I'll just shut if off and...

HORRORS!  There's no box to uncheck Word Wrap under the XML options.  But there is one for Comment Wrap under XML (so I can choose to wrap comments but not the entire document?)

Looks like it's on by default and I'm stuck with it?

Okay, I'm a clever guy...I'll just set the right margin to 99999 and...

I still get word wrap at 74 characters...  :D

Legitimate bug or did I screw up my configurations elsewhere?



hs2

  • Senior Community Member
  • Posts: 2737
  • Hero Points: 288
Re: XML wordwrap ALWAYS wordwraps
« Reply #1 on: September 09, 2008, 11:43:45 pm »
There are a number of related posts already availbale in tne forums. Just try Search: xml wrap
link1
link2
link3

Hope it helps,
HS2

skywise

  • Senior Community Member
  • Posts: 331
  • Hero Points: 10
Re: XML wordwrap ALWAYS wordwraps
« Reply #2 on: September 10, 2008, 05:40:29 pm »
Thanks, should've done that.  I just hand checked the previous 3 pages.  Turning the Content Wrap option off via the Document menu setting worked for me.

BTW, if you slickedit guys are reading, I agree with Chrisant's observations, here:

http://community.slickedit.com/index.php?topic=3143.0

But would add that Content Wrap should also be a checkbox option in the XML/HTML/etc language options (where Word Wrap usually is).

I'm "trained" now to go to the Tools | Language options and it was completely non-intuitive for me to look at the "Document" menu option.