Author Topic: "Mouse Over" Projects,Defs,Classes,Open,Build tabs won't work!!  (Read 3721 times)

forgetry

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
"Mouse Over" Projects,Defs,Classes,Open,Build tabs won't work!!
« on: September 10, 2008, 06:20:13 pm »
I am no longer able to mouse over to open the tabs for things such as Projects, Open, Build, etc.  Please help.

jimlangrunner

  • Senior Community Member
  • Posts: 358
  • Hero Points: 30
  • Jim Lang - always a student.
Re: "Mouse Over" Projects,Defs,Classes,Open,Build tabs won't work!!
« Reply #1 on: September 10, 2008, 07:08:49 pm »
Can you give a little more information?  Does the mouse pointer disappear?  Does it get stuck at the edge of the window?  Did your mouse break and you need keyboard shortcuts?  (Did the cat get it?)

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: "Mouse Over" Projects,Defs,Classes,Open,Build tabs won't work!!
« Reply #2 on: September 10, 2008, 07:15:59 pm »
I want it on the record that I easily could've posted another cat picture here, but that I didn't.

forgetry

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: "Mouse Over" Projects,Defs,Classes,Open,Build tabs won't work!!
« Reply #3 on: September 10, 2008, 07:28:12 pm »
For instance when I put my "Mouse Over" the "Open" tab, the tab doesn't pop out for me to open my files.  It also doesn't work if i click the tabs, but if I go to View/Toolbars/Open it pops open.  I can work around it but i would like the shortcut to work, Thanks

jimlangrunner

  • Senior Community Member
  • Posts: 358
  • Hero Points: 30
  • Jim Lang - always a student.
Re: "Mouse Over" Projects,Defs,Classes,Open,Build tabs won't work!!
« Reply #4 on: September 10, 2008, 07:54:46 pm »
Longshot, but here goes.

under Tools -> Options
Appearance -> Toolbars -> Options Tab
check box for "Auto Show tool window on mouse over"
also the delay box (10ths of a second).  Even 30 (3 seconds) would be a long time and cause me to look elsewhere.

Since the menu works (presumably via mouse action) and it's all your tool windows, that seems the likeliest.  (Can't think of the next likeliest)

Ryan, I'm going to look for the cat post.

forgetry

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: "Mouse Over" Projects,Defs,Classes,Open,Build tabs won't work!!
« Reply #5 on: September 10, 2008, 08:08:57 pm »
i can't find those options and i'm using v10

jimlangrunner

  • Senior Community Member
  • Posts: 358
  • Hero Points: 30
  • Jim Lang - always a student.
Re: "Mouse Over" Projects,Defs,Classes,Open,Build tabs won't work!!
« Reply #6 on: September 10, 2008, 09:50:34 pm »
Sorry, I never had version 10, and they totally reworked the options for V13, which is all I have now.  There has got to be a setting for mouseover in there somewhere.  (at least, I believe it should be in there.)  Anyone with V10 that knows where it is?  It's the "Auto Show tool window on Mouse Over" option (or equivalent) for toolbars.

Graeme

  • Senior Community Member
  • Posts: 2091
  • Hero Points: 252
Re: "Mouse Over" Projects,Defs,Classes,Open,Build tabs won't work!!
« Reply #7 on: September 11, 2008, 01:00:35 am »
I remember the mouse-over thing on those tabs dying regularly in version 10.  V10 was the first version that had those auto-hide tabs and I think the problem went away in version 11.  I don't remember if I ever found a solution for V10 but I may have had a cat back then.  The auto-hide thing is in view -> toolbars -> customise -> options.

If you want to try something, you could reload a couple of slick modules  - dockchannel.e and tbprops.e  - browse to them in the installation macros folder and use the macro -> load module command.

You could also try just deleting vslick.sta in your config folder (with slick closed).

Another thing to check is the _use_timers variable.  Use the set-var command on the cmd line (or macro -> set macro variable) and enter _use_timers  - make sure it has a value of 1.

You could also get the mouse-over thing working again by starting a new config folder  - use the -sc switch when you invoke slick e.g. vs.exe -sc c:\temp      - or wherever   -  then see if mouseover works.  Then consider copying over your existing config.

Once you get mouseover working again, think about backing up your config folder so if mouseover stops working, you can revert to a previous config.  If the problem is in the config folder, deleting vslick.sta should actually fix it though ...

Graeme

« Last Edit: September 11, 2008, 11:04:09 am by Graeme »