Author Topic: Leading whitespace on line joins  (Read 5301 times)

RobFreundlich

  • Community Member
  • Posts: 47
  • Hero Points: 2
Leading whitespace on line joins
« on: September 07, 2006, 07:23:02 pm »
Suppose I have the following text:

Code: [Select]
This is a test, it is only a test
    Related to moving back and forth
    with nav arrows?

I put the cursor after the word "forth" and hit the Delete key.  I end up with the following:

Code: [Select]
This is a test, it is only a test
    Related to moving back and forth    with nav arrows?

Notice all the space between "forth" and "with"?  In prior versions of SlickEdit (or possibly with my prior settings, I'd get this:

Code: [Select]
This is a test, it is only a test
    Related to moving back and forth with nav arrows?

which is actually what I want.

Is there a setting somewhere I can change to make it work this way?

hs2

  • Senior Community Member
  • Posts: 2737
  • Hero Points: 288
Re: Leading whitespace on line joins
« Reply #1 on: September 08, 2006, 01:30:29 pm »
Have a look into 'Tools->Options->Redefine Common Keys' to adjust your way of doing 'Delete'

HS2

RobFreundlich

  • Community Member
  • Posts: 47
  • Hero Points: 2
Re: Leading whitespace on line joins
« Reply #2 on: September 08, 2006, 05:09:30 pm »
Have a look into 'Tools->Options->Redefine Common Keys' to adjust your way of doing 'Delete'

I looked at that, and tried the various options without success.  Changing from "Linewrap Delete Char"  to "Delete Char" simply makes it not do the line join at all, and I couldn't find any combination of the other options that would do what I'm looking for.

Have you found something I missed?

Thanks,
Rob

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4791
  • Hero Points: 388
Re: Leading whitespace on line joins
« Reply #3 on: September 14, 2006, 02:55:15 pm »
Turn off "line wrap on text" in the Redefine Common Keys dialog.  Looks like the default was changed in Version 10.  Earlier version had this option off.  I'm not sure why delete is affected by this option but it is.

hs2

  • Senior Community Member
  • Posts: 2737
  • Hero Points: 288
Re: Leading whitespace on line joins
« Reply #4 on: September 14, 2006, 03:15:25 pm »
Just as add. example. This is my config:

HS2
« Last Edit: September 14, 2006, 03:17:44 pm by hs2 »

RobFreundlich

  • Community Member
  • Posts: 47
  • Hero Points: 2
Re: Leading whitespace on line joins
« Reply #5 on: September 14, 2006, 04:40:22 pm »
Turn off "line wrap on text" in the Redefine Common Keys dialog.  Looks like the default was changed in Version 10.  Earlier version had this option off.  I'm not sure why delete is affected by this option but it is.

That did it.  Thanks!