Author Topic: Text in "Search for" field is not auto-selected upon Find/Replace  (Read 3095 times)

je

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Text in "Search for" field is not auto-selected upon Find/Replace
« on: September 22, 2008, 04:47:21 pm »
About a week ago, I noticed that the behavior of my Find/Replace dialog has changed.  Formerly, whenever I would Find (Ctrl+F) or Replace (Ctrl-R), the text in the "Search for" field would appear highlighted/selected, such that the first key that I would press would replace the entire search field.  Now, no text in the "Search for" field is highlighted/selected, and the cursor is instead at the end of the text in the field; the first key that I would press is appended to the text already present.

Example ::

Formerly:
1.  Press Ctrl-F to bring up Find dialog.  The text in the "Search for" field was "temp", and is already highlighted/selected.
2.  Type "foo".
The "Search for" field now reads "foo"

Now:
1.  Press Ctrl-F to bring up Find dialog.  The text in the "Search for" field was "temp", and is already highlighted/selected.
2.  Type "foo".
The "Search for" field now reads "tempfoo"

Any idea how to correct this, such that I revert to the former behavior?

I am using SE v11.0.2.

TIA,
-jonathan
« Last Edit: September 22, 2008, 04:51:26 pm by je »

Graeme

  • Senior Community Member
  • Posts: 2279
  • Hero Points: 296
Re: Text in "Search for" field is not auto-selected upon Find/Replace
« Reply #1 on: September 23, 2008, 10:18:13 am »
Try opening the file tbfind.e from the slick installation macros folder  - unless there's a tbfind.e in the hotfix folder in your configuraton folder.  If you have both, open the version of tbfind.e that is newest and use the load module command on the macro menu to load it.  If that doesn't fix the problem, back up your configuration folder, then with slick closed, delete vslick.sta (vslick.stu on linux).  Then start slick and it will create a new state file.  Dunno if it will help but it might.

Graeme

je

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: Text in "Search for" field is not auto-selected upon Find/Replace
« Reply #2 on: September 23, 2008, 02:33:37 pm »
Try opening the file tbfind.e from the slick installation macros folder

this worked!  much appreciated...