Author Topic: How to stop embedded language coloring?  (Read 4604 times)

Ding Zhaojie

  • Senior Community Member
  • Posts: 191
  • Hero Points: 36
How to stop embedded language coloring?
« on: September 08, 2006, 07:53:57 am »
The embedded language coloring makes my gcc inline asm codes hard to read. How to disable this feature or make it coloring the gcc inline asm codes correctly? ???

Thanks.

hs2

  • Senior Community Member
  • Posts: 2725
  • Hero Points: 280
Re: How to stop embedded language coloring?
« Reply #1 on: September 08, 2006, 01:23:07 pm »
see 'Tools->Options->Color -> check 'Set embedded ...' and e.g. adjust the 'Window Text' background color ...

HS2

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2068
  • Hero Points: 256
Re: How to stop embedded language coloring?
« Reply #2 on: September 08, 2006, 01:56:02 pm »
Yes, the defaults definately didn't color that stuff just right.  Could you save us some typing and send that example (the code and screenshot) to support@slickedit.com?

Also, a few suggestions:

1) Go to Tools > Options > Color Coding...

2) Select the "asm" lexer

3) Go to the "Strings" tab and turn on "search for end quote across multiple lines"

4) Go to the "Numbers" tab and turn on "C-style" for hex numbers

5) Go to the "Tokens" tab and add the keywords that your assembler expects, and
    also remove the ones that do not apply to your assembly language.

You should be able to customize the color coding to look a lot better.  If you make significant changes and make it just perfect, maybe your should post the modified lexer (it will be in user.vlx in your configuration directory) to HS2's thread on colors.

Ding Zhaojie

  • Senior Community Member
  • Posts: 191
  • Hero Points: 36
Re: How to stop embedded language coloring?
« Reply #3 on: September 08, 2006, 03:16:02 pm »
Yes, the defaults definately didn't color that stuff just right.  Could you save us some typing and send that example (the code and screenshot) to support@slickedit.com?

Also, a few suggestions:

1) Go to Tools > Options > Color Coding...

2) Select the "asm" lexer

3) Go to the "Strings" tab and turn on "search for end quote across multiple lines"

4) Go to the "Numbers" tab and turn on "C-style" for hex numbers

5) Go to the "Tokens" tab and add the keywords that your assembler expects, and
    also remove the ones that do not apply to your assembly language.

You should be able to customize the color coding to look a lot better.  If you make significant changes and make it just perfect, maybe your should post the modified lexer (it will be in user.vlx in your configuration directory) to HS2's thread on colors.


Hi, thanks for your suggestions. Now my codes look much better now. But the lexer seems confused with the gcc inline assembly template. You can see the paren matching highlight was wrong.

The gcc inline assembly is much different with others. It needs to support many assembly languages (e.g. x86, PPC, MIPS, ARM...) so the inline asm codes are "assembler template" string but not pure asm codes. I think it is really hard to highlight the template string, but just let user turn off the embedded language coloring for some file types is much easier and helpful.

You can find the gcc inline assembly brief here:
http://www-128.ibm.com/developerworks/library/l-ia.html#h1
« Last Edit: September 08, 2006, 03:17:36 pm by Ding Zhaojie »

hs2

  • Senior Community Member
  • Posts: 2725
  • Hero Points: 280
Re: How to stop embedded language coloring?
« Reply #4 on: July 31, 2007, 02:27:59 pm »
@SlickTeam:
Since v12.02 the inline assembly support is much better. Thanks again Dennis !
I'd like to add another feature request concerning the GNU inline assembly templates as described by Ding.
On 'push-tag' for a template parameter (which is most probably a variable defined somewhere in the 'containing' source) only the 'current lang. mode' tag files are used to find the tag. Because we are inside the embedded assembly I assume that only 'Assembler' tag files are considered, which are not existing and therefore '... not found'.
Hence I'd propose to determine the containing lang. mode and retry with the corresponding tagfiles in that case.

Do you think it's possible to do (later) or makes any sense ?

HS2

timur

  • Senior Community Member
  • Posts: 120
  • Hero Points: 0
Re: How to stop embedded language coloring?
« Reply #5 on: June 16, 2008, 04:59:44 pm »
I'm still using Slickedit 11.  If I can't fix the highlighting for inline asm, how do I turn it off?  I just don't want to see the gray background color any more.