Author Topic: Calling only aliases  (Read 8928 times)

afflictedd2

  • Guest
Calling only aliases
« on: December 14, 2008, 04:11:41 pm »
Hi everyone,

I've been trying to use some aliases I created for C/C++, however other autocompletion variables, and other stuff takes over, and I can't find my alias.
My alias is like this:

inc ---> #include "%\c"
Inc ---> #include <%\c>

In Slickedit I write inc and then Ctrl + Space, but it either completes something else or lists stuff where I can't find my alias. Is it possible maybe to set the Tab key to complete this alias?


Graeme

  • Senior Community Member
  • Posts: 1978
  • Hero Points: 226
Re: Calling only aliases
« Reply #1 on: December 15, 2008, 11:09:05 am »
Try using the space key to complete the alias, instead of ctrl-space - seems to work for me, though according to the help, you'd think ctrl-space would be required!  Perhaps ctrl-space applies when you type less than the name of the alias.  On the auto-complete tab, you can turn off whether you get automatic completion for aliases or not.

Graeme

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Calling only aliases
« Reply #2 on: December 19, 2008, 04:06:57 pm »
I just tested this and got the same result. I'm looking into it. In the meantime, there is a function called "expand-alias", which is bound to Ctrl+Shift+O in the CUA emulation. That will expand the alias without any other form of completions getting in the way.

Interestingly, this is not mentioned in the User Guide. So, I'll make sure we get that updated too.