Author Topic: Huge file chokes SlickEdit  (Read 4888 times)

Wanderer

  • Senior Community Member
  • Posts: 557
  • Hero Points: 23
Huge file chokes SlickEdit
« on: September 21, 2006, 12:13:25 am »
Hello,
I just loaded a 19 meg xml file.  It appeared quickly, but as soon as I try to scroll, SlickEdit freezes for 10 - 40 seconds.  When it comes back, I can scroll maybe 5 - 8 lines, and SlickEdit wanders off again for another break....
What are the options to help SlickEdit deal with such a large file?
Thanks.

SlickEdit 11.0.2, WinXP pro sp2.
-----------------------------------
In the Defs window:  FILE IS TOO LARGE! Context information is not generated.
« Last Edit: September 21, 2006, 01:44:52 pm by Wanderer »

hs2

  • Senior Community Member
  • Posts: 2747
  • Hero Points: 288
Re: Huge file chokes SlickEdit
« Reply #1 on: September 21, 2006, 07:56:40 am »
I quick workaround is to switch to 'Document->Select Mode->fundamental' to disable all syntax support.

I think it's related to tagging.
Unfortunately I don't not know how to disable tagging only while leaving the colorizer intact.

HS2

hs2

  • Senior Community Member
  • Posts: 2747
  • Hero Points: 288
Re: Huge file chokes SlickEdit
« Reply #2 on: September 21, 2006, 11:29:32 am »
Workaround #2
Maybe you could add a new file extension e.g. 'bigxml' setup (and rename your file accordingly)
w/o referring to 'xml' type but
w/ specifying the xml lexer.
So at least you should get your file colorized...

HS2

Wanderer

  • Senior Community Member
  • Posts: 557
  • Hero Points: 23
Re: Huge file chokes SlickEdit
« Reply #3 on: September 21, 2006, 01:46:44 pm »

Maybe you could add a new file extension e.g. 'bigxml' setup (and rename your file accordingly)
w/o referring to 'xml' type but
w/ specifying the xml lexer.
So at least you should get your file colorized...
HS2

Thanks for the suggestion.  Fortunately, it is actually a .kml file, so I don't have to mess around with renaming.  If I map .kml to fundamental, and set the lexer to xml, I get the syntax coloring and normal performance.

(I wonder if I could write a macro that would toggle the kml 'refers to' setting...)

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5270
  • Hero Points: 432
Re: Huge file chokes SlickEdit
« Reply #4 on: September 21, 2006, 01:52:42 pm »
There are some XML performance fixes I added for V11.02.   Contact support if you want these fixes.

These fixes improve the situation A LOT but the work around described about turns off all smart editing and does perform faster.  You may want to try these fixes out.

One performance problem is that the "Max size of files to tag (bytes)" for background tagging was being ignored in an important case (no work around for this fix).  In addition, the "Highlight matching blocks" Tools->Options->General Options->More Tab will also be automatically turned off for large files.  You can turn this off now but it will effect all XML files you edit.

With the new changes, you can further tweak things by changing the "Max size of files to tag (bytes)" and setting the macro variable def_xml_max_smart_editing to a smaller value.  This macro variable setting is not yet available from a dialog.  The macro variable def_xml_max_smart_editing is already available in V11.02 but it gets ignored by the "Highlight matching blocks" feature