Author Topic: [Error] Projects file context menu broken.  (Read 3398 times)

donjoe

  • Community Member
  • Posts: 35
  • Hero Points: 1
[Error] Projects file context menu broken.
« on: March 13, 2009, 12:15:26 pm »
I just installed v12.0.3 (plus cumulative hotfix) on a new workstation and everything seems to be working fine except for one thing I've never had problems with before: if I open/unhide the Projects toolbar and right-click a file from the currently open project, I get a Slick-C Stack window and a Slick-C Error dialog as you can see in the attached screenshot.

The Projects folders context menu works fine (so if I right-click "Sources" or "Headers" or "Resources" everything's OK), the problem only affects the files themselves.

I've run the installation kit and chosen "Repair" and then reinstalled the hotfix. No luck.

Does anyone have any idea what I could try next?
« Last Edit: March 13, 2009, 12:17:37 pm by donjoe »

Graeme

  • Senior Community Member
  • Posts: 2432
  • Hero Points: 322
Re: [Error] Projects file context menu broken.
« Reply #1 on: March 13, 2009, 01:11:45 pm »
If you open the file ptoolbar.e from the slick macros folder and type st -f 15242 on the slick command line you'll be taken to the AddVCMenu function in ptoolbar.e.  The code there assumes that the context menu that you get when you right click in the main editor window (_ext_menu_default) has a "Version Control" entry.  If that menu doesn't contain a "Version Control" entry you'll get the error you're seeing.  I don't know if that's you're problem though since it doesn't sound like you've changed that menu  - however, just in case, right click in the main editor window and see if there is a "Version Control" item in the menu.  If not, you could try adding a "dummy" Version Control entry into that menu  - select the "edit this menu" item at the end of the menu.  You need to add at least one sub menu to the "Version Control" menu by checking the sub-menu checkbox and entering a name for the sub-menu.

If that's not the problem, some other things you could do are
1. If you don't want a version control item in the project toolbar context menu, go to line 2640 in ptoolbar.e and comment out the call to AddVCMenu  - save the file and use the load module command on the macro menu to load it.

alternatively
2. In the AddVCMenu function in ptoolbar.e, check if the return value from the call to _menu_find_caption is less or equal to zero and exit the function (return) if it is.  Save and load the module.

alternatively
3. Select the "menus" option from the macro menu and edit the _projecttb_file_menu  -  delete the "Version Control" item from the menu if you don't want it.

alternatively
4. Start slickedit with a brand new configuration folder using the -sc switch  - i.e. vs.exe -sc c:/new-empty-folder, then open your project and see if right click in the project toolbar fails on a file.

alternatively
5. Sometimes, just rebuilding a slick module can fix a problem so open ptoolbar.e and use the load module command on the macro menu to load it.  If this works, option 4 above should have worked.

I'm out of ideas...

Graeme
« Last Edit: March 13, 2009, 01:19:07 pm by Graeme »

donjoe

  • Community Member
  • Posts: 35
  • Hero Points: 1
Re: [Error] Projects file context menu broken.
« Reply #2 on: March 13, 2009, 03:15:53 pm »
If that menu doesn't contain a "Version Control" entry you'll get the error you're seeing.  I don't know if that's your problem though since it doesn't sound like you've changed that menu
Of course it doesn't, I didn't go on to describe every little bit of personalization and configuration I did. :) But yes, I did customize that menu: I deleted everything I didn't understand or see the need for, including the "Version Control" option. I think I should be able to do that without problems when there's an "Edit this menu" option. :-\

Quote
you could try adding a "dummy" Version Control entry into that menu  - select the "edit this menu" item at the end of the menu.  You need to add at least one sub menu to the "Version Control" menu by checking the sub-menu checkbox and entering a name for the sub-menu.
OK, thanks! It works now.