Author Topic: Error starting debugger  (Read 5534 times)

Dave_Sinkula

  • Community Member
  • Posts: 27
  • Hero Points: 4
Error starting debugger
« on: September 21, 2006, 03:25:35 pm »
I am just getting to know v11.0.2 and I wanted to try the debugger for a Gnu C/C++ project. When I tried it, I received the attached popup message.

Where do I need to start looking for some settings or options to change?

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2920
  • Hero Points: 438
Re: Error starting debugger
« Reply #1 on: September 21, 2006, 08:49:57 pm »
The gdb executable that we ship with SlickEdit depends on cygwin1.dll.  If you do not have Cygwin installed on your machine and in your path, it won't be able to start.  If you have cygwin installed, but it is an old, incompatible version of cygwin1.dll, again, GDB won't start.

We get a lot of complaints about this, especially from the MinGW clan, but it's only recently that a normal human being could actually build a stock GDB with MinGW, and we've found the cygwin solution to be the most stable and general purpose version.  The reason that we do not ship cygwin1.dll with our product is to avoid redundancy and avoid people picking up the wrong cygwin1.dll for other applications.

If you have your own GDB executable you want to use, go to Debug > Debugger Options, GDB Configurations tab, and point SlickEdit at your GDB and set that to be your default native debugger.

Dave_Sinkula

  • Community Member
  • Posts: 27
  • Hero Points: 4
Re: Error starting debugger
« Reply #2 on: September 21, 2006, 09:12:13 pm »
The gdb executable that we ship with SlickEdit depends on cygwin1.dll.  If you do not have Cygwin installed on your machine and in your path, it won't be able to start.  If you have cygwin installed, but it is an old, incompatible version of cygwin1.dll, again, GDB won't start.
That would seem to be the reason given that I have neither installed on this machine.

If you have your own GDB executable you want to use, go to Debug > Debugger Options, GDB Configurations tab, and point SlickEdit at your GDB and set that to be your default native debugger.
This fixed it. Thank you. :)

By the way (for those who may run into this same issue), this setup was using gcc and gdb from Code::Blocks. So adding that version of gdb got the debugger up and running.