Author Topic: Slickedit Core crashing eclipse  (Read 6584 times)

rickmcguire

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Slickedit Core crashing eclipse
« on: May 12, 2009, 06:42:43 pm »
I just purchased the 3.4 version of Slickedit Core and installed it on Eclipse Ganymede 3.4.2.  The install appeared to have gone ok, SlickEdit is the default editor in the Java view.  However, when I first opened a file, I got the prompt for installing the license file, then a tabbed window with the license information, followed by the dialog for selecting the key emulation.  After hitting OK on the key emulation dialog, eclipse just "goes away". 

When I relaunch eclipse and try again, I get the same behavior (minus the install the license file dialog).  So far, I can't say I'm particularly impressed!  What do I need to resolve this situation and get editting again?

Rick

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Slickedit Core crashing eclipse
« Reply #1 on: May 12, 2009, 06:50:39 pm »
Can you try opening Eclipse with a new workspace, instead of your existing workspace?  I'm betting that this will rectify the situation.  When you have the new workspace open you can make sure the plug-in activates by just selecting any SlickEdit menu item from the main menu, like Help > About SlickEdit Core. 

Then try switching back to your regular workspace...is everything ok now?  Let me know...I'd also like a copy of the .log file from the offending workspace which is at WORKSPACE_DIR/.metadata/.log , if you could.  Feel free to attach it to a post.

- Ryan

rickmcguire

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Slickedit Core crashing eclipse
« Reply #2 on: May 12, 2009, 07:28:04 pm »
Yes, doing this cleared up the problem.  Thanks for the timely assistance!

Gavin Melville

  • Junior Community Member
  • Posts: 6
  • Hero Points: 0
Re: Slickedit Core crashing eclipse
« Reply #3 on: June 04, 2009, 12:35:53 am »
Hi Ryan,

I've got the same problem, but changing workspaces hasn't fixed it.  I can load a source file into the editor, but the instant I click in that edit window the entire Eclipse environment exists  instantly.   Log files from the new workspace and the old one attached.

Regards,
Gavin Melville.

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Slickedit Core crashing eclipse
« Reply #4 on: June 04, 2009, 01:11:46 am »
If you are crashing when you click in the edit window that's definitely a different problem.  By looking at the logs, you have some other 3rd party plug-ins installed into this environment, yes?  For example, what is com.wavecom.openat.ide.wcc.core?  I see some "String index out of range" exceptions being thrown from there...have you tried Core in an IDE without any of this other software?  Unfortunately it is sometimes the case that our editor plug-in doesn't play well with other plug-ins, and we don't know about it until someone reports it  :-\.  I'm wondering if this is what is going on, based on the exceptions I'm seeing in the log file.

I'm not sure exactly what is causing the crash, I can't tell directly from the logs...but if you could try Core in a "vanilla" Eclipse with your same code just as a test that would really help.  If it's not crashing anymore I can try to replicate your environment and see if I can't get it to exhibit the same problems, and then I should be able to see what's going on.

- Ryan


Gavin Melville

  • Junior Community Member
  • Posts: 6
  • Hero Points: 0
Re: Slickedit Core crashing eclipse
« Reply #5 on: June 04, 2009, 09:49:39 pm »
Hi Ryan,

Not so easy.  This is a Wavecom supplied development environment -- a multi gigabyte monster, and the inbuilt editor is a bit of a dog, hence wanting to try Slickedit.   At this point I don't have the time to  install a clean Eclipse, and trying to install all the Wavecom supplied stuff into Eclipse would be a nightmare.

Thanks,
Gavin Melville.

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Slickedit Core crashing eclipse
« Reply #6 on: June 04, 2009, 10:02:01 pm »
I see...is there anyway I could get a copy of the IDE?  That would be the best, if you are aware of how I might go about that.

It shouldn't take all that long to just download the Classic version of Ganymede, and then install Core.  That's all I was looking for...I didn't want you to then install all the Wavecom plug-ins...this was only for a test, to see if you could load up the same code with that environment to see if it crashed or not.  I understand about the time, though.

I don't know what kind of files you are working with, but have you tried this with any other files?  Does it crash no matter what?

One thing we can do is run Eclipse with the SlickEdit debug tracing enabled, assuming you can pass a command line argument to Eclipse with the environment you are using.  Just open a command line to the directory where your executable is, and launch it like this (using eclipse.exe as the executable in this example, which may or may not be the case with your IDE):

Code: [Select]
.\eclipse.exe -vstrace > test.out

That will launch Eclipse, and then you can open up a file, get it to crash, and then post test.out so that I can have a look.  It should have a bunch of trace statements.

- Ryan

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Slickedit Core crashing eclipse
« Reply #7 on: June 05, 2009, 06:02:56 pm »
I was able to download the IDE at http://www.wavecom.com/media/files/products/M2Mstudio/download/ .  I hope it's the right product/version...I had a lot of trouble getting it to install, but it finally worked.  Unfortunately I've been unable to successfully install SlickEdit Core b/c I can't get the Update Manager to run inside the IDE  :-[.  The p2 update engine keeps throwing an exception about the registry directory not being available...

But, I think I see why it's crashing when you click in an editor window.  We had this same problem inside of standard Eclipse before we released version 3.2 of our plug-in, and it looks to be the same issue...I had to dig up the bug report to make sure.

Basically Eclipse <= 3.1 used older window controls, akin to what SlickEdit <= 10 looked like.  It also happens to be exactly how this Wavecom IDE looks, even though it is apparently based on Eclipse 3.4.  In SlickEdit v11 we updated our controls to be a newer, more XP-ish style, and when we were building the next version of the plug-in (based on SlickEdit v11) we first tested it in Eclipse 3.1.x...even though it was to be compatible with Eclipse 3.2.

We had the same crash you are experiencing, right when we clicked in the editor window.  Eclipse also updated their look in 3.2, and we were once again compatible, and had no crash from that point forward.  I suspect it's the same incompatibility lurking here...I'm not entirely sure of the specifics, this was about 3 full years ago.  The only thing you could do would be to install a much older version of our plug-in, which probably doesn't interest you  :(.

Thanks for bringing this to our attention, I'm sure you won't be the only one to come across this issue.

- Ryan