Author Topic: Problem with 14.00.01.02 d/l  (Read 2043 times)

Wanderer

  • Senior Community Member
  • Posts: 557
  • Hero Points: 23
Problem with 14.00.01.02 d/l
« on: May 15, 2009, 11:11:42 pm »
I went to my Registered Products page, clicked on the link to download SlickEdit for Windows.
Click on the link to d/l 14.00.01.02, save se_14000102_win.msi.
When I install it, the splash screen says "SlickEdit 2009 (14.0.1)", and installs in to C:\Program Files\SlickEditV14.0.1.

What's going on?

Graeme

  • Senior Community Member
  • Posts: 2235
  • Hero Points: 278
Re: Problem with 14.00.01.02 d/l
« Reply #1 on: May 16, 2009, 12:25:58 am »
I guess for the same reason that 14.0.0.7 installs (by default) to the same place as 14.0.0.5.  Most people won't want to keep the previous installation  - but you can if you want to.  I usually keep the previous installation when the third digit (1.2.3) changes.

Graeme

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Problem with 14.00.01.02 d/l
« Reply #2 on: May 18, 2009, 03:54:13 pm »
The first three numbers comprise the logical version number. We use the fourth to disambiguate different builds of a release. So, v14.0.0 and v14.0.1 area planned releases of the product. We may produce a number of release candidates, both internal and external, which are tracked using the fourth digit, like v14.0.0.5 and v14.0.0.7, but we treat both of those as v14.0.0 since they are two builds of the same thing.

We want it to be easy to keep multiple versions of SlickEdit on your machine, if for no other reason than it makes it easier on us to test and support the product.  ;)  However, we didn't think it made sense to treat different builds of the same release the same way as different releases.

As previously pointed out, you do have the option of overriding the default install directory if you choose. I hope this helps you to better understand our nomenclature.