Author Topic: 14.0.1.2: Fast open wildcards not working anymore.  (Read 3726 times)

lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
14.0.1.2: Fast open wildcards not working anymore.
« on: May 25, 2009, 06:28:25 am »
In version 14.0.0.7 we were able to use wildcards in the path names:

    gripapi/*/*/*/main.cpp
    gripapi/*/unittest/src/main.cpp
    unit*/src/main.cpp

And so forth. In version 14.0.1.2 this is no longer possible, the entire path needs to be entered.

This makes me sad  :( The wildcard matching was so cool.

Can we have it back?

--
Greg.

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: 14.0.1.2: Fast open wildcards not working anymore.
« Reply #1 on: May 25, 2009, 10:43:45 am »
Do you mean in the smart_open dialog?  I'm guessing it's an accidental casualty of the performance improvements to the smart_open dialog in 14.0.1.

The forward slashes as directory separators make me think you're probably using *nix or etc.  But if by chance you are using Windows, then if it's important enough to you then as a workaround you might be able to use this macro in the meantime until path wildcarding is available again in smart_open.

lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
Re: 14.0.1.2: Fast open wildcards not working anymore.
« Reply #2 on: May 25, 2009, 10:57:57 pm »
Hi Mate.

Yes I do mean smart open. I'll have a look at the macro, thanks!

Cheers,
--
Greg.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6455
  • Hero Points: 503
Re: 14.0.1.2: Fast open wildcards not working anymore.
« Reply #3 on: May 28, 2009, 08:24:54 pm »
This bug is not in the macro.  It's in the C++ code. We will have this fixed in the next update.