Author Topic: tab expansion not displaying correctly on longer lines  (Read 4919 times)

Peter Steinberg

  • Community Member
  • Posts: 14
  • Hero Points: 2
tab expansion not displaying correctly on longer lines
« on: May 26, 2009, 10:57:00 pm »
In a 'C' file, with the options set to indent with tabs, and tabs set to "+4", there are instances where the a small box will be displayed instead of tabbing out to the correct column.

For example, try the attached one line file.

(It also happens in a plain text file with the tabs set to "+8").

Thanks,
  Peter Steinberg

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: tab expansion not displaying correctly on longer lines
« Reply #1 on: May 27, 2009, 01:35:02 am »
It seems like past column 256 hard tab characters are not expanded anymore.

Peter Steinberg

  • Community Member
  • Posts: 14
  • Hero Points: 2
Re: tab expansion not displaying correctly on longer lines
« Reply #2 on: May 27, 2009, 02:48:46 pm »
That was my first thought, but if you change the last tab that displayed properly to two space characters, the next tab will then display properly.

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: tab expansion not displaying correctly on longer lines
« Reply #3 on: May 27, 2009, 07:03:26 pm »
chrisant is correct; by default SlickEdit doesn't expand tabs past column 256. You can override this by setting tabs to "1 1024 +4", or use a larger value than 1024 if needed.

Peter Steinberg

  • Community Member
  • Posts: 14
  • Hero Points: 2
Re: tab expansion not displaying correctly on longer lines
« Reply #4 on: May 27, 2009, 07:13:04 pm »
That works, thanks.

Now how do I easily set the default for all languages to having a larger margin?

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: tab expansion not displaying correctly on longer lines
« Reply #5 on: May 27, 2009, 07:28:11 pm »
It depends on what you mean by "margin". If you are referring to the grayish vertical area to the left of the editor window (but still within the editor pane), you can set that by visiting Tools > Options > Appearance > General. Set the value for "Window left margin" to something bigger.

If you are referring to a region of whitespace within a file created by Word Wrap, then that must be set on a language-by-language basis...sorry.

Peter Steinberg

  • Community Member
  • Posts: 14
  • Hero Points: 2
Re: tab expansion not displaying correctly on longer lines
« Reply #6 on: May 27, 2009, 07:36:53 pm »
I'm referring to the "1024" referenced in the "tabs" command you listed.

It's nice having all the customization for various languages, but a way to set the default value for all of them would be nice.

hs2

  • Senior Community Member
  • Posts: 2747
  • Hero Points: 288
Re: tab expansion not displaying correctly on longer lines
« Reply #7 on: May 27, 2009, 08:26:15 pm »
@Peter: It's already on the feature list. See here. So maybe one day... ;)
HS2