SlickEdit Product Discussion > Slick-C® Macro Programming

Changes in _form source not reflected when form displayed

(1/2) > >>

Aaron:
When I make changes to the source of a form, later when that object is displayed my changes are not reflected.  I am using version 7.0.1.  Any ideas as to what is going on?

Graeme:

I don't have version 7 but ...

How long have you been using this particular form?
Have you been able to change the form successfully before?
Has anything changed on your system recently e.g. new operating system.
Have you tried unloading and reloading the form?
If you change the associated source file do the changes work?

Have you tried starting a new config directory to see if it works there - use -sc switch on the command line that invokes slickedit, then copy over your forms and macro files and rebuild them.  To copy over a form, use macro menu, then "insert form or menu source".  You probably need to add #include "vslick.sh" at the top of the form file.  Then you could check if the design time view of your form agrees with what you see now.

Graeme

Aaron:
I've been able to change the form but cannot reproduce what I did, it always seems to be a bit of luck.
I have tried loading the form as a module, (with the include "vslick.sh" at the top) and then calling it from my macro with no luck.  I also tried commenting out the include statement and then just including the form file into my macro file.

If I unload the form and macros, and then change the source of the form, and reload that module, the changes are NOT reflected.  Even if I unload, quit the program, come back and load it.  No good.

What DOES work is if I change the form name.  If I just change the name then the changes are reflected.  But this is very annoying-- every time I make a change to my form I have to for example change "_form gui" to "_form gui2" and then in my show statement change it there as well.

But I think the fact that if rename it changes immediately take effect mean SlickEdit is keeping the old forms in memory, even when I unload the modules.  I will look into the -sc switch as well.  Thanks for the reply!

Graeme:

It sounds like there's a reasonable chance starting a new config directory and state file will solve the problem.  Copying your settings etc from your old config to a new one can be a bit of a challenge but it's a good way to get a clean start, especially if you've been "experimenting" with macros.

You might be able to achieve the same thing more easily by deleting your state file but I've never tried that.  Either way, you can reload the settings that are kept in vusrdefs.e just by entering the full path and name of vusrdefs.e on the slick command line (with quotes around the pathname if it has spaces in it) and pressing return.  You could probably make a full copy of your existing config directory, then try deleting the state file etc. and if it doesn't work out, restore the config directory.  I guess you'll need to save all your forms and menus in source form first if you haven't already.

Graeme

Aaron:
Would I have to do this every time I make changes to the form?

Anyways, I don't have a vusrdefs.e.  I will try to reset configuration to default other ways.  Thanks for taking the time to help me!

Navigation

[0] Message Index

[#] Next page

Go to full version