Author Topic: cutting/copying text from slickedit and pasting into another application  (Read 4578 times)

schugh

  • Community Member
  • Posts: 26
  • Hero Points: 0
Hello, I've found this strange behaviour.
I am using the latest version of slickedit.
When I cut/copy text out of slickedit and past it into say Word or Excel, the coloring is all messed up.
The text is pasted but it's invisible! My background is the default white in Word or Excel, and the pasted text is also white!
I have to select the pasted text and click the "automatic" coloring option in Word or Excel.
And yes, the settings in Word and Excel are the default settings, it's not because the setting in those apps is wrong, as I was typing just fine in those apps prior to pasting the text from slickedit.
I thought you might ask this obvious question so I am letting you know it's not the office apps. :)

-- Sanjay

chrisant

  • Senior Community Member
  • Posts: 1413
  • Hero Points: 131
What version of SlickEdit?
What version of Office?
What version of Windows?  (Or is it Mac?)

I use SE14 with Office 2007 on Windows 7, Windows Vista, and Windows 2008.
Pasting colored text into Word 2007 works fine for me with the default settings.
It has also worked fine with SE13 with Office 2007.
I upgraded to Office 2007 before I started using SE, so I haven't tried with Office 2003.
« Last Edit: June 11, 2009, 07:11:51 pm by chrisant »

davehohl

  • Senior Community Member
  • Posts: 263
  • Hero Points: 21
I am using SE 14.0.1.2 on Windows XP SP3 with Office 2003.  Pasting into Word and Excel work fine for me.

Phil Barila

  • Senior Community Member
  • Posts: 746
  • Hero Points: 61
Is it possible that your SE color scheme results in white text on the clipboard?

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1100
  • Hero Points: 94
Are you pasting plain-text or are you using HTML or RTF enabled clipboards in SlickEdit?  Or if you choose the Paste Special option in Word, which clipboard format is causing the problem? 

With the HTML clipboard, the clipboard is surrounded by a <div> with the background color and default-font style defined in inline style attributes.  You get a nicer looking paste, since it matches the syntax coloring and backgrounds as set in SlickEdit.  Is it possible you have some style sheet element enabled in your documents that would override this?

schugh

  • Community Member
  • Posts: 26
  • Hero Points: 0
SE 14.0.1.2
Office 2003.
Windows XP SP2
I just checked my SE settings, and indeed there is an option for RTF or HTML clipboards and in my case HTML is selected.
I guess that must be the default setting? I didn't set it myself.
I just tried copying and pasting again.
I am using the black theme in Slickedit.
When I pasted into Word 2003, it was ok, only the pasted text was just as in slickedit with the same coloring and black background.
I tried it in Excel and the coloring is all messed up. I guess it doesn't like HTML clipboard formats.
Maybe I only remember Word being a problem. It might only have been Excel.

Anyway, I turned off the HTML clipboard option in SE and it's working fine now as plain text.

Thanks,

-- Sanjay

Phil Barila

  • Senior Community Member
  • Posts: 746
  • Hero Points: 61
You might also consider checking both.  I don't remember what problem it solved, but when I discovered those two checkboxes, I wasn't satisfied with either option alone, I ended up checking both to get all the behavior I wanted.  I don't know if one takes precedence over the other and I just tested poorly, or if there really are two copies of the text on the clipboard, but I was only satisfied by having them both.