Author Topic: FILE IS TOO LARGE! Context information is not generated.  (Read 6102 times)

rburchett

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
FILE IS TOO LARGE! Context information is not generated.
« on: August 06, 2009, 12:32:57 am »
I get this error when I open a large header file in slickedit.  Try as I might, I can find no where to adjust the item to which the error refers.
FILE IS TOO LARGE!  Context information is not generated.  Try adjusting 'def_update_context_max_file_size' 

There should never be an error message for which there is no help in a commercial product like this.

I've added version particulars to the end.  Anyone know how to get rid of this error?  I can still move around in the file ok, it's just annoying.

SlickEdit Version 12.0.3.0

Serial number:
Licensed number of users: Single user

Build Date: August 14, 2007
Emulation: Vim

OS: Linux
OS Version: Red Hat Enterprise Linux AS release 4 (Nahant Update 6)
Kernel Level: 2.6.9-55.ELsmp
Build Version: #1 SMP Fri Apr 20 17:03:35 EDT 2007
X Server Vendor: The X.Org Foundation

Installation Directory: /opt/slickedit/

Spill File: /tmp/$slk.foo.19983

Hotfixes:
/.slickedit/hotfixes/hotfix_se1203_cumulative.zip (Revision: 35)

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: FILE IS TOO LARGE! Context information is not generated.
« Reply #1 on: August 06, 2009, 06:00:27 am »
SlickEdit has all kinds of adjustable settings.  Too many to put in Tools|Options, it would be confusing and overwhelming.  The various "def_blahblah" kind of settings are adjusted via the "set-var" command at the SlickEdit command line.  It would be nice for the error message to at least point at the "set-var" command, it seems to assume a certain level of familiarity with SE that may not be true in all cases.

In CUA and most emulations press Escape to get to the SlickEdit command line.  Then type set-var def_update_context_max_file_size (it will show autocompletions for you as you type), then press Enter, then adjust the value.

It is defined in the macros\context.e file (you can use "f symbolname" at the SlickEdit command line to find symbols), and initialized to a default value of 4MB.

The warning is letting us users know that the context features will not be available in that file.  It's probably good there is a warning, otherwise the product would seem to mysteriously not work, and we'd be complaining about the lack of a warning. :)  Increasing the value of def_update_context_max_file_size could make it take longer for SlickEdit to open large files -- so you might prefer to increase the value.

Graeme

  • Senior Community Member
  • Posts: 2447
  • Hero Points: 322
Re: FILE IS TOO LARGE! Context information is not generated.
« Reply #2 on: August 06, 2009, 10:18:28 am »
From looking in context.e that Chris mentioned, there's a comment that says

"Indicate that the current buffer is to large to tag in the background."

So I guess with large files, the time taken to do background tagging as the file is changed could make the editor slow to respond to keypresses.  Perhaps the warning shouldn't be given until you actually change something in the file, and you're right - the error message is cryptic.

Graeme

Mike

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 100
  • Hero Points: 20
Re: FILE IS TOO LARGE! Context information is not generated.
« Reply #3 on: August 07, 2009, 06:06:14 pm »
FYI: Another place to set macro variables like these (def_) is here:
'Macro > Set Macro Variable...'


rburchett

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: FILE IS TOO LARGE! Context information is not generated.
« Reply #4 on: August 07, 2009, 06:13:02 pm »
Adjusting that variable did the trick.  Is there a list of macro values somewhere?  The support person I talked to made mention of some macro documentation, but in .../slickedit/docs I find only two, one has to do with "slick-c macro programming" - pretty sure that's NOT what I'm looking for and the other is best practices.  Neither really seem to explain what those "macro" variables are all about.  Take this snippet from the latter for example:

Modifying macros that ship with SlickEdit
Don't do it! Take your hands away from the keyboard.

So obviously, they don't want people mucking around in their macros.  But they should explain them somewhere just for things like this.

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: FILE IS TOO LARGE! Context information is not generated.
« Reply #5 on: August 07, 2009, 06:40:23 pm »
The "Don't do it" quote is in reference to modifying the macro files that we ship as part of SlickEdit. A great deal of the functionality in SlickEdit is written in the Slick-C macro language and contained in the macros subdirectory. Many of our users do modify these files, which is why we ship the source. We just don't want people storing their modifications in that directory.

The best practice is to create a file or multiple files with your own macro code in it. If you modify some SlickEdit code, put it in your own file. When you load it, it will replace our definition for the same function.

As for macro variables, those exist to easily change the behavior of SlickEdit. Some are set through the Options screens, while others have no GUI associated with them. While it is by no means a comprehensive list, you can find some of the more important ones in the User Guide under Appendix > Configuration Variables > Table of Configuration Variables.