Author Topic: SlickEdit Core v3.5 for Eclipse Now Available  (Read 4241 times)

Jeffrey

  • Community Administrator
  • Senior Community Member
  • *
  • Posts: 222
  • Hero Points: 18
SlickEdit Core v3.5 for Eclipse Now Available
« on: August 24, 2009, 03:42:28 pm »
SlickEdit Inc. announces the release of SlickEdit Core v3.5 for Eclipse. This release supports Eclipse Galileo, version 3.5, and is updated with the latest capabilities from SlickEdit 2009.

Some important notes about this release:

  • SlickEdit Core is a subscription that allows you to run any supported version. We recognize that many people cannot immediately move to the new version of Eclipse. So you may continue to run SlickEdit Core v3.4.

  • SlickEdit Core v3.5 is written for and tested on Eclipse version 3.5. We do not support this version of SlickEdit Core on any previous version of Eclipse.

  • SlickEdit Core is installed using the Eclipse Software Updates manager. We recommend that you uninstall any previous version of SlickEdit Core prior to installing this version to the same instance of Eclipse.

  • If you participated in the SlickEdit Core Beta program, be sure to follow the instructions below for how to remove the beta version. The steps are more complicated because the plug-in names and versions are the same.

Installing SlickEdit Core in a Clean Instance of Eclipse

To download and install SlickEdit Core:

  • Open Eclipse and select Help > Install New Software.

  • Make sure that Group items by category is checked, and click the Add button.

  • In the Add Site dialog, enter the following URL into the Location field: https://customer.slickedit.com/update/secore/galileo.

  • Expand the tree node for Code Editing, and then click the check box for the SlickEdit Core for Eclipse feature.

  • Click the Next button.

  • Follow the instructions in the installation wizard to accept the licensing agreement and install SlickEdit Core for Eclipse.

   
Uninstalling the SlickEdit Core v3.5 Beta Version

Please read this thoroughly and be sure to follow these instructions to remove the SlickEdit Core v3.5 beta version.

Since the plug-in names and versions for both the official release and the beta release are the same, the Eclipse plug-in installation mechanism (p2) will be confused when you attempt to uninstall the beta and install the official version.  By accurately following the steps listed below, you will ensure that you have a clean installation of the official SlickEdit Core for Eclipse v3.5.0 release, without having to re-install Eclipse or lose any of your SlickEdit settings.

  • Remove the beta update site URL from the Install Wizard: Go to Help > Install New Software, click on the Available Software Sites link at the top of the dialog (just below the Add button), select the https://customer.slickedit.com/update/secore/galileo/site.xml entry, and click Remove.  Click OK to close the dialog.

  • Add the new release update site URL using the Install Wizard: https://customer.slickedit.com/update/secore/galileo (no trailing site.xml this time).

  • Uninstall the beta: Go to Help > Install New Software, click on the “What is already installed?” link at the bottom of the dialog, select SlickEdit Core for Eclipse, and click the Uninstall button.  You will be prompted to restart Eclipse.  Close Eclipse after the restart.

    This will remove the SlickEdit features from the ECLIPSE/features directory, but will not remove the plug-ins from the ECLIPSE/plugins directory.  We need these directories to be deleted in order to ensure that the official release will be downloaded, however we need p2 (the Eclipse plug-in installation mechanism) to delete them for us so that it is not confused.

  • In your file explorer, go to the ECLIPSE/plugins directory, delete the contents of any com.slickedit.* directories, leaving the directories themselves, empty.  On either platform there should be between 4 and 7 directories, depending on which components were installed.

    IMPORTANT LINUX NOTE: Now create an empty plugins/com.slickedit.linux.libs_3.5.0/slickedit directory.  There is an installation action which occurs on this directory and installation will throw an error if it does not exist.

  • Re-install SlickEdit Core for Eclipse.  This will only take a few seconds because Eclipse will not actually install anything.

  • Uninstall SlickEdit Core for Eclipse, again.  This will also only take a few seconds.  The com.slickedit.* directories should now be removed by Eclipse during this uninstall.

  • Install SlickEdit Core for Eclipse. This step does the normal installation of the plug-in.

After restarting Eclipse, the official release of SlickEdit Core 3.5.0 should be installed.  To double check, go to Help > About SlickEdit Core, and look at the build date on the Program Information tab.  It should be August 17, not July 17 (the date of the beta release).

The SlickEdit Team
« Last Edit: August 24, 2009, 03:46:45 pm by Jason »