Author Topic: SlickEdit Core Cannot Start  (Read 4708 times)

srasul

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
SlickEdit Core Cannot Start
« on: September 01, 2009, 03:03:23 pm »
Hi,

i just downloaded and installed slickedit core as per: http://www.slickedit.com/trial/slickedit-core

when i started up eclipse after the install, for each slickedit action i do, i get a dialog box saying: The chosen action is not currently available.

in my error logs i see this:

org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException: An error occurred while automatically activating bundle com.slickedit.eclipse.plugin (402).
   at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:125)
   at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:449)
   at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:211)
   at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:376)
   at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:452)
   at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:405)
   at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:393)
   at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
   at org.eclipse.osgi.internal.loader.BundleLoader.loadClass(BundleLoader.java:321)
   at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:231)
   at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1193)
   at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160)
   at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:874)
   at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
   at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
   at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugin.java:267)
   at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
   at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(WorkbenchPlugin.java:263)
   at org.eclipse.ui.internal.PluginAction.createDelegate(PluginAction.java:122)
   at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:223)
   at org.eclipse.ui.internal.WWinPluginAction.runWithEvent(WWinPluginAction.java:229)
   at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
   at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
   at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
   at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1176)
   at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3493)
   at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3112)
   at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
   at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
   at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
   at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
   at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
   at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
   at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
   at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
   at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
   at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
   at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
   at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
Caused by: org.osgi.framework.BundleException: Exception in com.slickedit.eclipse.SlickEditPlugin.start() of bundle com.slickedit.eclipse.plugin.
   at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:805)
   at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:754)
   at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:352)
   at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:280)
   at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:408)
   at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
   ... 49 more
Caused by: java.lang.Exception: SlickEdit Core Cannot Start.
   at com.slickedit.eclipse.SlickEditPlugin.start(SlickEditPlugin.java:508)
   at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:782)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:773)
   ... 54 more

I am running eclipse 3.5 64 bit with java 1.6.0_15 64bit on ubuntu 9.04 64 bit.

i just wanted to try out slickedit core. but it does not seem to work for me.
« Last Edit: October 07, 2016, 08:38:48 pm by Rodney »

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: SlickEdit Core Cannot Start
« Reply #1 on: September 01, 2009, 03:10:28 pm »
SlickEdit Core (and SlickEdit standalone) are not 64 bit applications.  You need to have the 32 bit libraries installed on your system, and be running a 32 bit JVM in order to start SlickEdit Core (http://www.slickedit.com/products/slickedit-core/slickedit-core-for-eclipse-system-requirements).

We are looking into making our plug-in 64 bit for our next release...sorry for the inconvenience  :(.

- Ryan

srasul

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: SlickEdit Core Cannot Start
« Reply #2 on: September 02, 2009, 08:13:36 am »
ok thanks for the info. i will wait for the 64 bit versions. i have too many eclipse projects in my workspace and so i need the 64bit eclipse.