Author Topic: "Save workspace files" sometimes doesn't  (Read 2330 times)

dunkers

  • Senior Community Member
  • Posts: 653
  • Hero Points: 28
"Save workspace files" sometimes doesn't
« on: September 03, 2009, 02:22:48 am »
If a new file is added to a project via File|New... and then a build is performed before first saving the file, the file is not auto-saved before building. Once the file has been manually saved a build will cause an auto-save if appropriate.

Admittedly, not something that happens every day :)

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: "Save workspace files" sometimes doesn't
« Reply #1 on: September 03, 2009, 02:07:36 pm »
I can't reproduce this problem. I used one of my simple GNU C/C++ workspaces with the "Build without a makefile" option selected on the Build tab of Project Properties. I selected New > File, typed in a filename, and made sure that "Add to project" was checked. I pasted some code into the new buffer. Then I selected Build > Build. The file was saved and compiled.

Let me know if there are any key differences in your process so we can figure this one out.

dunkers

  • Senior Community Member
  • Posts: 653
  • Hero Points: 28
Re: "Save workspace files" sometimes doesn't
« Reply #2 on: September 03, 2009, 03:28:23 pm »
Sorry, user error on this one:

I've just switched over to Win7 on a new PC and when adding the new file the tickbox "Add to project" was unticked. Over on the old setup that's always been ticked, so my eyes never see this anymorem, and it never occured to me that this is something not copied with the config.

I can confirm that if this is ticked the file is saved correctly.

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: "Save workspace files" sometimes doesn't
« Reply #3 on: September 03, 2009, 03:34:22 pm »
Excellent!  If only all of life's problems were so easily solved.