Author Topic: SlickEdit core For Eclipse ...requires plug-in "org.eclipse.jdt.launching"  (Read 8279 times)

brebey

  • Community Member
  • Posts: 55
  • Hero Points: 2
I'm trying to install the SlickEdit core trial into Eclipse/Flex Builder 3 on Windows.  When I follow the instructions to install SlickEdit core, I get an error message that says 'SlickEdit Core For Eclipse (Windows) (3.3.1) requires plug-in "org.eclipse.jdt.launching".'

How/where do I get "org.eclipse.jdt.launching"?

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: SlickEdit core For Eclipse ...requires plug-in "org.eclipse.jdt.launching"
« Reply #1 on: September 08, 2009, 02:57:35 pm »
'SlickEdit Core For Eclipse (Windows) (3.3.1) requires plug-in "org.eclipse.jdt.launching".' is just a cryptic way of Eclipse telling you that the 3.3.1 version of our plug-in requires the JDT, which is not installed by default in Flex Builder.

Go to Help > Software Updates > Find and Install > Search for new features to install and select Europa Discovery Site in the tree and click Finish.  If that site is not included in your Install Wizard, you can manually add it...the URL is http://download.eclipse.org/releases/europa/ .  When the site comes up, expand the Java Development category and install the 'Java Development Tools' plug-in.  I forget the exact name.  That should get you what you need...hope this helps  :).

- Ryan

brebey

  • Community Member
  • Posts: 55
  • Hero Points: 2
Re: SlickEdit core For Eclipse ...requires plug-in "org.eclipse.jdt.launching"
« Reply #2 on: September 08, 2009, 10:29:17 pm »
Thanks Ryan!  That got me going in the right direction.  I'm having Version Confusion, though.

I'm using the trial of SECore, which appears to be 3.3.1.  There appears to be a patch that makes SECore work properly in FlexBuilder 3, but the directions in the forum and in the Readme installation instructions refer to SECore 3.4.  The current SECore available on the forum appears to be 3.5.

Does anyone one know what I really need?  Can I install the Flex patch to my 3.3.1 SECore version, or do I need 3.4 before installing the patch?  If I need 3.4, how do I get a trial of that?

Can I install the latest-greatest SECore 3.5 to FlexBuilder 3 instead of either 3.3.1 or 3.4?  If so, does it require the FlexBuilder patch that's supposed to go with 3.4, or does 3.5 not require the patch?  If I should be installing 3.5, how do I get a trial of that?

After installing SECore 3.3.1, I now get a Java NULL Exception error on FlexBuilder 3 startup, and am instructed to view the error log.  I can't figure out where/how to view the error log, though.  Any ideas?

Thanks to any/all who can help!

Bill

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: SlickEdit core For Eclipse ...requires plug-in "org.eclipse.jdt.launching"
« Reply #3 on: September 09, 2009, 02:35:29 pm »
Yes, that patch was built for SlickEdit Core 3.4.0...that is the version that you want.  The SlickEdit Core trial page should show you directions on how to install Core 3.4.0: http://www.slickedit.com/index.php?option=com_content&view=article&id=61 .  It should be pretty easy if you are using Eclipse 3.4 with the FlexBuilder 3 plug-in.

Were you seeing a different trial download page?  I ask because our website was reworked recently, and if there was a problem I would like to know about it.

I would uninstall Core 3.3.1 and install the 3.4.0 version of our plug-in, and then install the patch posted in this forum.

Now, as far as Core 3.5.0 is concerned...we didn't test or release a Flex integration plug-in for Core 3.5.0, partly because even Adobe's new product (still in beta...http://labs.adobe.com/technologies/flashbuilder4/) doesn't support Eclipse 3.5.x.  We will likely look at doing something for the 3.5.0 version of our plug-in soon, but I'm not yet sure what that will be.  I would stick with Core 3.4.0 right now.

Hope this helps.

- Ryan

brebey

  • Community Member
  • Posts: 55
  • Hero Points: 2
Re: SlickEdit core For Eclipse ...requires plug-in "org.eclipse.jdt.launching"
« Reply #4 on: September 09, 2009, 07:41:44 pm »
The SlickEdit Core Web Site must be a bit scrambled or something, because following the instructions at "http://www.slickedit.com/trials/slickedit-core-trial/slickedit-core-trial-download",  when I get to the "Select Features To Install" dialog, the tree looks like this:
Code: [Select]
   SlickEdit Core [this is an arbitrary name I chose for the Remote Site]
   +--Code Editing
      +--SlickEdit Core for Eclipse 3.3.1

3.4 is not listed at all
.  Is there an alternate method by which I can install 3.4 into Eclipse/FlexBuilder 3?


Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: SlickEdit core For Eclipse ...requires plug-in "org.eclipse.jdt.launching"
« Reply #5 on: September 09, 2009, 08:20:04 pm »
Ok...I think I see what is going on.  There is an error on the page where it lists the URL for the 3.4.0 update site.  It should read: https://customer.slickedit.com/update/secore/ganymede/ NOT https://customer.slickedit.com/update/secore/ .  Does this solve the issue?

- Ryan

brebey

  • Community Member
  • Posts: 55
  • Hero Points: 2
Re: SlickEdit core For Eclipse ...requires plug-in "org.eclipse.jdt.launching"
« Reply #6 on: September 09, 2009, 09:02:50 pm »
Yep - that did the trick!  Core 3.4 is now installed, the patch is applied, and all seems to be working well.

Thanks for the help!

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: SlickEdit core For Eclipse ...requires plug-in "org.eclipse.jdt.launching"
« Reply #7 on: September 09, 2009, 09:13:24 pm »
Glad to hear it...sorry for the confusion.  The web page has been corrected.

- Ryan