Author Topic: SlickEdit Version 11.0.1 Problem  (Read 7933 times)

mana_

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
SlickEdit Version 11.0.1 Problem
« on: June 28, 2006, 04:10:03 am »
When open the *.sln(vc 7.1), it give me a message box:
Project '*.vcproj' is not recognized as valid.
??

Graeme

  • Senior Community Member
  • Posts: 2727
  • Hero Points: 337
Re: SlickEdit Version 11.0.1 Problem
« Reply #1 on: June 28, 2006, 07:41:38 am »

Opening a VC7.1 (visual studio 2003) solution file in slick V11.0.1 works fine for me.  You need to select the file with the .sln extension when you open it, not the file with the .vcproj extension.  If you select the vcproj file you'll get an error message similar to what you describe.  If this isn't the problem, can you list the exact steps that you are doing that give the error.

Graeme

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 366
  • Hero Points: 26
Re: SlickEdit Version 11.0.1 Problem
« Reply #2 on: June 28, 2006, 01:42:28 pm »
You may also get this error when your project file (.vcproj) is located on a remote share and you no longer have access to that share/drive.

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: SlickEdit Version 11.0.1 Problem
« Reply #3 on: July 01, 2006, 04:04:42 am »
I've also seen this problem when you save the .sln and/or .vcproj files as Unicode. Once you save a sln or vcproj file as Unicode, Visual Studio likes to run with it and keep saving with that encoding. Go back to Visual Studio and open the project. Close any open documents, highlight the project in Solution explorer, and go the menu command File | Save  projectname as.... Select ANSI Project File from the Save as Type drop-down and save it. (Or try UTF-8 if some of the settings or file names in your project have unicode characters). Then close the solution, and try it again from SlickEdit.


mana_

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: SlickEdit Version 11.0.1 Problem
« Reply #4 on: July 02, 2006, 04:01:51 pm »
I've also seen this problem when you save the .sln and/or .vcproj files as Unicode. Once you save a sln or vcproj file as Unicode, Visual Studio likes to run with it and keep saving with that encoding. Go back to Visual Studio and open the project. Close any open documents, highlight the project in Solution explorer, and go the menu command File | Save  projectname as.... Select ANSI Project File from the Save as Type drop-down and save it. (Or try UTF-8 if some of the settings or file names in your project have unicode characters). Then close the solution, and try it again from SlickEdit.



Thanks very much.I can open it now! ;D

evil84

  • New Community Member
  • Posts: 1
  • Hero Points: 0
Re: SlickEdit Version 11.0.1 Problem
« Reply #5 on: June 08, 2008, 08:13:27 am »
thaks u very much, i also find this problem, and ur's words helping me solute it. thank u again.