Author Topic: Error installing Slickedit Core Trial For Eclipse 3.5.x  (Read 4239 times)

swells

  • Community Member
  • Posts: 12
  • Hero Points: 0
Error installing Slickedit Core Trial For Eclipse 3.5.x
« on: September 18, 2009, 10:42:47 pm »
Hello,

When I follow the instructions on http://www.slickedit.com/index.php?option=com_content&view=article&id=61&Itemid=136 to
install the Slickedit Core trial (I have Eclipse 3.5 PHP developers with C/C++ Perspective)

I get the following error after the download process:

An error occurred while installing the items
  session context was:(profile=epp.package.php, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]com.slickedit.linux.libs 3.5.0, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.ChmodAction).
  The action chmod failed - file /opt/eclipse/eclipse/plugins/com.slickedit.linux.libs_3.5.0/slickedit does not exist.

Any ideas?  I'm using Eclipse on Fedora 11 64-bit.

Thanks!

-Scott

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Error installing Slickedit Core Trial For Eclipse 3.5.x
« Reply #1 on: September 21, 2009, 02:13:08 pm »
Hi, thanks for the interest in SlickEdit Core.  Sorry you are having trouble with the install...did you happen to have the 3.5 beta installed into this same Eclipse installation?  The error you received is exactly what you would get if you had the beta and didn't follow all the uninstallation steps before installing the official version.  Unfortunately, there are some hoops to jump through due to the way the Eclipse installation mechanism works.  If this is the case, see http://community.slickedit.com/index.php?topic=5141.0 .

I noticed you are installing into the /opt directory.  Are you installing as a user who has write access to this directory?  During the install, Eclipse will try to set permissions on that directory you see in the error message (/opt/eclipse/eclipse/plugins/com.slickedit.linux.libs_3.5.0/slickedit), and if you didn't have access then that directory wouldn't be there.

Other than this, have you tried reinstalling?  There shouldn't be any installation issues just because you are using 64-bit Linux, but our plug-in does require that you are running with a 32-bit JVM, as a 64-bit JVM will not load the 32-bit SlickEdit libraries.  See my reply here: http://community.slickedit.com/index.php?topic=5159.0 .

Hope this helps...let me know how it goes.

- Ryan

swells

  • Community Member
  • Posts: 12
  • Hero Points: 0
Re: Error installing Slickedit Core Trial For Eclipse 3.5.x
« Reply #2 on: September 21, 2009, 06:36:20 pm »
Thanks for the quick reply, Ryan!

No, I did not install the 3.5 beta of Eclipse (or a beta of Core).

I am using Eclipse from a user that has write permissions, and I've installed other perspectives and software successfully from eclipse as that user.
The com.slickedit.linux.libs_3.5.0/slickedit directory isn't there, so I'm not quite sure why.

I have Slickedt 14 for Linux, and I got it to work on my Fedora 11 64-bit system by installing the libXt.i586 package.
So I'll use Slickedit to code, at least until a 64-bit Slickedit Core is released.

If I need to pursue this more, I'll post again.

Thanks!

-Scott