Author Topic: SlickEdit core for eclipse with Wind River work bench and sparx  (Read 4393 times)

ronen.bitan

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
SlickEdit core for eclipse with Wind River work bench and sparx
« on: October 15, 2009, 06:41:58 pm »
I'm using SlickEdit for years. Now we are about to work with Wind River's workbench and sparxs enterprise architect and I want to work with it all integrated.
I download eclipse SDK version 3.4.1 and installed Workbench 3.1 into eclipse and insllated Sparx as plugin. Now I have difficulties installing the SlickEdit core for eclipse:
My eclipse help>Software updates... open a window other than the "Help > Software Updates > Find and Install" menthioned on the support page, and don't succseed to find or install the SlickEdit core. (Error: No repository found at https://customer.slickedit.com/update/secore/ganymede
  Error reading update site https://customer.slickedit.com/update/secore/ganymede.
  Connection timed out: connect)
Did the same directly on Wind River's work bench (there I have "Help > Software Updates > Find and Install" and it couldn't open the SlickEdit  as well. (Error: No repository found at https://customer.slickedit.com/update/secore/ganymede
  Error reading update site https://customer.slickedit.com/update/secore/ganymede.
  Connection timed out: connect)

Please assist.
Thanks

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: SlickEdit core for eclipse with Wind River work bench and sparx
« Reply #1 on: October 15, 2009, 07:58:35 pm »
Quote
My eclipse help>Software updates... open a window other than the "Help > Software Updates > Find and Install" menthioned on the support page

Sorry...the download instructions for 3.5 are correct, but it looks like the instructions for 3.4 are actually the instructions for 3.3.  We reworked our entire website a while ago, and it looks like something got lost in translation.  Also, it would be nice if Eclipse didn't change their plug-in installation GUI every single release...anyways, I'll get that paged fixed ASAP.  Here are the actual instructions for 3.4:

  • In Eclipse, select Help > Software Updates and select the 'Available Software' tab
  • Click the Add Site button, enter the SlickEdit Core Update URL: https://customer.slickedit.com/update/secore/ganymede and click OK
  • Expand the tree node for SlickEdit Core Update Site, and under the Code Editing category and mark the check box for 'SlickEdit Core for Eclipse'
  • Click the Install button
  • Follow the instructions in the installation wizard to accept the licensing agreement and install SlickEdit Core for Eclipse

Now, it appears as if this site for our 3.4.0 plug-in is behaving a little bit flaky, right now.  The Eclipse installation wizard was showing me some bizarre configurations in the tree, and it was being slower than normal.  I had IT check on the site itself, and nothing appears to be wrong.  What you should be seeing is in the picture attached...try using the Refresh button on the 'Available Software' tab if the Eclipse Software Update wizard is giving you issues.

If you are still having issues after following these instructions, it's possible that you cannot access the update site behind your company's firewall (or something similar).  This happens occasionally.  If this is the case, we can get you an offline installer for Core 3.4.0 so you don't have you use the Eclipse installation mechanism.  Just PM me an e-mail address and we will be able to get that to you.

Hope this helps.

- Ryan

ronen.bitan

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: SlickEdit core for eclipse with Wind River work bench and sparx
« Reply #2 on: October 18, 2009, 05:37:20 am »
Thanks Ryan. Still having issues ("No repository found at https://customer.slickedit.com/update/secore/ganymede""), probably as you said - firewall. I'm sending you my address in PM.