Author Topic: Install Error - eclipse 3.5 - ubuntu 9.10  (Read 24414 times)

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #15 on: January 11, 2010, 08:24:46 pm »
I understand...I think you could still use Java 5 to build and run your applications, and use Java 6 just to run Eclipse.  You should be able to set that up within Eclipse, you would just have to change the JDK for each project.

- Ryan

sparklinghari

  • Community Member
  • Posts: 9
  • Hero Points: 1
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #16 on: January 20, 2010, 12:55:22 pm »
Hi Ryan,

Sorry for the late response. Got caught up in a training.

As you suggested, I uninstalled Java 5 and installed Java 6 in my Linux machine. SlickEdit core is working fine now. Thanks for your help.

So now we can conclude that SlickEdit core has the dependency on Java 6.

However, as I had already informed, I want to use SlickEdit for Eclipse for Android Source which has the dependency on Java 5. Do you mean to say if I have to use Java 5 for build and Java 6 for Eclipse, should I disable "automatic build" in Eclipse IDE?

Do you have any plans to support Java 5 also? Please clarify.

Thanks and regards,
Hariprasad

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #17 on: January 20, 2010, 03:45:42 pm »
Hmm...yea I knew Core 3.5.0 depends on Java 1.6.0, we've had other threads about that, but I never thought that the error you were seeing had to do with the Java version  ???.  At any rate, at least we figured out the issue.

Quote
However, as I had already informed, I want to use SlickEdit for Eclipse for Android Source which has the dependency on Java 5. Do you mean to say if I have to use Java 5 for build and Java 6 for Eclipse, should I disable "automatic build" in Eclipse IDE?

I don't think you have to disable automatic build, just first make sure that you are starting Eclipse with Java 6 (so that Core runs).  Now in your Eclipse workspace, right-click on your Android project and select Properties.  Select the Java Compiler node, and as shown in the attached picture, set the compliance level for 1.5.  Click OK and apply the settings.  I think this should do it.

Quote
Do you have any plans to support Java 5 also? Please clarify.

Yes, for our next release we plan on running with Java 5 or later.

Let me know if the above instructions work for you.

- Ryan

sparklinghari

  • Community Member
  • Posts: 9
  • Hero Points: 1
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #18 on: January 21, 2010, 06:36:04 am »
Hi Ryan,

It works now. I am able to build the source using Eclipse with the compliance level for 1.5.

I have a basic doubt with Java settings (I am not sure if I can ask you). Lets say I have Java 1.5 also installed in my Ubuntu. How do I set to use Java 1.5 or Java 1.6? Should I keep changing the environment variables and Java alternatives every time I want to switch between the versions? It will be great and highly helpful If you know and share the same.

Thanks and regards,
Hariprasad

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #19 on: January 21, 2010, 03:37:39 pm »
I am guessing you want to keep Java 1.5 in your PATH, but start Eclipse using Java 1.6, and not have to keep changing your PATH environment variable all the time?  This you can do by specifying the vm argument to Eclipse.  To tell Eclipse what Java to use, you can do the following on the command line:

Quote
./eclipse -vm /PATH/TO/JAVA/6/bin/java

You can put this in the eclipse.ini file (located in the Eclipse root directory) so that you don't have to specify it on the command line every time (or write a script).  Just make sure that the -vm argument comes before the -vmargs arguments in the .ini file, because those arguments are passed directly to the vm.  Here is an example of what my .ini file looked like after I changed it:

Quote
-startup
plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vm
/usr/java/jdk1.6.0_16/bin/java
-vmargs
-Xms40m
-Xmx256m
-Xss1024k

Once you have this specified you can just start Eclipse, and it will start using the specified Java each time.

Does this help?  Now, if you want to change what version of Java you are using to run Eclipse a lot, I suggest just making a couple scripts, each of which will start Eclipse with the desired -vm argument.  This way you don't have to keep specifying the argument on the command line, or keep editing the .ini file.

- Ryan

sparklinghari

  • Community Member
  • Posts: 9
  • Hero Points: 1
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #20 on: January 22, 2010, 05:51:24 am »
Thanks a lot for your assistance, Ryan. Highly appreciated. 8) :)

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #21 on: January 22, 2010, 02:41:18 pm »
You're welcome, and thanks a lot for your patience...threads like this help all of our users to get around problems like these  :).

- Ryan

Jasey_Wang

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #22 on: February 08, 2010, 05:19:34 pm »
You're welcome, and thanks a lot for your patience...threads like this help all of our users to get around problems like these  :).

- Ryan


hello,I am not very good at english.so the expression may be poor:(

 i happen to the same problem.
whenever i start running eclipse on Ubuntu 9.10.it says:
(eclipse:3018): GLib-WARNING **: g_set_prgname() called multiple times
i google a lot.and found 2 ways at the moment.
1)http://ubuntuforums.org/showthread.php?t=1362942
2)http://mou.me.uk/2009/10/31/fixing-eclipse-in-ubuntu-9-10-karmic-koala/
i did so as they told me .but my eclipse still cant work:(
so please ?
i am a sophomore from China.
thank you a lot!

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #23 on: February 08, 2010, 05:45:53 pm »
Greetings,

You need to make sure you are using a 32-bit Java from Sun (not gcj that is included on the system), as well as 32-bit Eclipse.  You also need to make sure you are using Java 1.6.0 or later for Core 3.5.0.

Are you positive that all of these requirements are met?  If this is the case, and Eclipse with SlickEdit still won't work, can you run Eclipse as follows, from the command line:

Code: [Select]
./eclipse -vstrace

When Eclipse starts, do something SlickEdit related, like go to Help > About SlickEdit Core and after you get an error, go back to the command line and copy the output.  Now paste it here so I can take a look.

One other thing you might want to try as a test, is to start Eclipse with a brand new workspace, and see if that makes any difference.

- Ryan

Jasey_Wang

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #24 on: February 09, 2010, 04:15:36 pm »
Greetings,

You need to make sure you are using a 32-bit Java from Sun (not gcj that is included on the system), as well as 32-bit Eclipse.  You also need to make sure you are using Java 1.6.0 or later for Core 3.5.0.

Are you positive that all of these requirements are met?  If this is the case, and Eclipse with SlickEdit still won't work, can you run Eclipse as follows, from the command line:

Code: [Select]
./eclipse -vstrace

When Eclipse starts, do something SlickEdit related, like go to Help > About SlickEdit Core and after you get an error, go back to the command line and copy the output.  Now paste it here so I can take a look.

One other thing you might want to try as a test, is to start Eclipse with a brand new workspace, and see if that makes any difference.

- Ryan

thanks for your help!
my ubuntu is 9.10 desktop
 JDK:jdk-6u18-linux-i586.bin
eclipse :Release 3.5.1
1) cd /usr/local/src/eclipse
2) ./eclipse
and it work ,but the console says :


wyx@wyx-laptop:/usr/local/src/eclipse$ ./eclipse -vstrace

(eclipse:16220): GLib-WARNING **: g_set_prgname() called multiple times
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0077a856, pid=16220, tid=3079157440
#
# JRE version: 6.0_18-b07
# Java VM: Java HotSpot(TM) Client VM (16.0-b13 mixed mode, sharing linux-x86 )
# Problematic frame:
# C  [libpango-1.0.so.0+0x23856]  pango_layout_new+0x36
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid16220.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

 whenever i enter "next",it does not work --!
you can see the pic as follows
thanks for your help !

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #25 on: February 09, 2010, 04:50:01 pm »
Did Eclipse run fine before you installed SlickEdit Core?  Or had you not tried that?  If not, you should definitely try that because there is no output from SlickEdit before that seg fault.  Install a clean Eclipse and try doing the same things you are doing now.

I'd be curious to know if that works or not, because there are a lot of postings in various places about libpango crashes on Ubuntu with Eclipse.  I'll keep looking and see if I can find anything that looks promising.

- Ryan

Jasey_Wang

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: Install Error - eclipse 3.5 - ubuntu 9.10
« Reply #26 on: February 13, 2010, 12:26:08 pm »
Did Eclipse run fine before you installed SlickEdit Core?  Or had you not tried that?  If not, you should definitely try that because there is no output from SlickEdit before that seg fault.  Install a clean Eclipse and try doing the same things you are doing now.

I'd be curious to know if that works or not, because there are a lot of postings in various places about libpango crashes on Ubuntu with Eclipse.  I'll keep looking and see if I can find anything that looks promising.

- Ryan

i really appreciate your effort for helping me :)
i now installed virtual box and  eclipse in the Vb can work now--!
thanks anyway:-)