Author Topic: Vertical Line Gone in UTF-8?  (Read 2423 times)

jim

  • Community Member
  • Posts: 30
  • Hero Points: 1
Vertical Line Gone in UTF-8?
« on: November 19, 2009, 04:46:29 pm »
Hi folks,

I recently changed my encoding to UTF-8 (under File Options -> Load).  When I did so, I lost my vertical line at column 80.  Under fonts, for element "Unicode Source Windows", I am using Lucide Console, and I have checked the "Use fixed spacing for bold and italic fixed Unicode font", but my vertical line has still not returned.  Is there something else I can try?

Thanks!

Jim

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Vertical Line Gone in UTF-8?
« Reply #1 on: November 20, 2009, 04:33:35 pm »
Did you check to see that Appearance > General > Vertical Line Column is still non-zero? Also, is the color still set to something visible? I'm trying to determine if this problem is caused by the option being turned off or whether this is a rendering problem. Also, what OS are you using and what version of SlickEdit. I cannot reproduce this issue on v14.0.2.2 on Windows.

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Vertical Line Gone in UTF-8?
« Reply #2 on: November 20, 2009, 04:40:22 pm »
Two other thoughts:
1) Is Lucida Console a fixed width font on your system? We cannot render the vertical line column for proportional fonts because it wouldn't be a straight line.
2) What font size did you choose? If the font is larger then before, the line at 80 columns may be drawn farther to the right and you have to scroll to see it.

jim

  • Community Member
  • Posts: 30
  • Hero Points: 1
Re: Vertical Line Gone in UTF-8?
« Reply #3 on: November 20, 2009, 05:34:34 pm »
Hi Scott, thanks for the reply!  I meant to write earlier this morning, but it turns out a reboot (or at least a restart of SE) fixed it. I did have the vertical line set to non-zero and a visible color, but it didn't show up when I checked the "Use fixed spacing for bold and italic fixed Unicode font", which I thought for sure would fix it based on another thread.  When it didn't (after checking the box and hitting "apply"), I wrote in for help.  I didn't realize that some settings wouldn't take effect until after a restart.

Thanks again!

Jim

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Vertical Line Gone in UTF-8?
« Reply #4 on: November 20, 2009, 07:02:49 pm »
Glad you figured it out! I didn't have to restart after applying the same settings, so I'm not sure what I did differently. The important thing is that things are working for you.