Author Topic: no vertical line?  (Read 6030 times)

Stu

  • Community Member
  • Posts: 59
  • Hero Points: 0
no vertical line?
« on: December 06, 2009, 07:24:25 pm »
I just purchased a license and am loving it, slowly converting my keybindings from jedit + eclipse over..

one thing has me stumped, I have no vertical line. Under options->general I have "vertical line column" as 80 and vertical line colour as something not the same as the background.

but nothing displays. I can't quite figure out what else I need to do to get it to display.

I have my config in git so when I changed it I saw it change the option "_default_option('R','76');" from 80 to 76, so I know its changing + saving it in the config but I just get no visible output on the screen. Help says it wont work in a unicode file or proportional font.. neither of which apply to me.. unless of course having utf8 makes it automatically unicode.. I changed the options->file options->load->encoding to "Text" but nothing changed. I then changed the language extension for C to text again, nothing changed...

anyone have any insights?

jimlangrunner

  • Senior Community Member
  • Posts: 360
  • Hero Points: 31
  • Jim Lang - always a student.
Re: no vertical line?
« Reply #1 on: December 06, 2009, 09:07:36 pm »
I seem to recall something similar.  It does have to be a fixed-space font, and unicode boogers it up.  Try a different font maybe?  Like Courier - one that I know works.  Under fonts - choose "Fixed fonts only" to make sure you've got it.

Other than that I have nothing.

Stu

  • Community Member
  • Posts: 59
  • Hero Points: 0
Re: no vertical line?
« Reply #2 on: December 06, 2009, 09:22:26 pm »
Thanks I tried, Consolas, Courier New, Terminal, Dejva Sans Mono, Liberation Mono, Andal Mono, Bitstream Vera Sans Mono. nada. I went back to Monaco which is my preferred font.


chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: no vertical line?
« Reply #3 on: December 06, 2009, 11:02:04 pm »
This topic might help.

Stu

  • Community Member
  • Posts: 59
  • Hero Points: 0
Re: no vertical line?
« Reply #4 on: December 07, 2009, 12:07:02 am »
I cant find any options in v14 that look anything like what was proposed in your solution :(

Ding Zhaojie

  • Senior Community Member
  • Posts: 194
  • Hero Points: 37
Re: no vertical line?
« Reply #5 on: December 07, 2009, 01:24:31 am »
Make sure you are using a fixed width font, and set the vertical line column and color here.

Stu

  • Community Member
  • Posts: 59
  • Hero Points: 0
Re: no vertical line?
« Reply #6 on: December 07, 2009, 01:46:30 am »
both "sbcs/dbcs source windows" and "unicode source windows" are set to courier new, vertical line column is at 80. 

I have no vertical line drawn on the screen.



Stu

  • Community Member
  • Posts: 59
  • Hero Points: 0
Re: no vertical line?
« Reply #7 on: December 07, 2009, 02:07:19 am »
ok fixed it. what a pain in the butt.

options -> file options -> load -> encoding = "text"
options -> languages -> extension manager -> c -> encoding = "Text, SBCS/DBCS mode"

My font de jure "monaco" whilst being fixed width is not I guess, fixed with "enough" for it to count, so changing to consolas or andale mono makes the vertical line appear. The reason it did not appear the first time is it bizarrely had 50 copies of my working file open, and it put a vertical rule on only 1 of those.. I closed all windows, and opened one.. it appeared.

I've decided to go without so I can use the font I like the most. :( Seems kind of arbitrary that you can only get a vertical rule on some fixed width fonts and not others.



chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: no vertical line?
« Reply #8 on: December 07, 2009, 11:05:50 pm »
Oh yeah -- settings are remembered per window -- gotta close the window and recreate it to pick up the new settings.