Author Topic: next-file does not work flipping back and forth between two untitled new buffers  (Read 2276 times)

Ian P

  • Community Member
  • Posts: 59
  • Hero Points: 2
Hi,

I just upgraded from SE 2007 to 2009, and one problem that I was hoping would be fixed is still there. I have smart next window turned on and two function keys (F7/F8) bound to "next-window" and "next-buff-tab" so that F8 lets me page sequentially through the file tabs, and F7 lets me flip back-and forth between the last two tabs viewed. The latter I find great when I have two versions of the same file open for spotting differences in them, and I use that quite a lot.

The problem is that next-window does not work on Untitled buffers created created via the "create empty buffer to edit" button. Say I have two files fil1 and file2 open, and two untitled buffers. If I view file1 followed by file2 and the repeatedly execute next-file it will flip back and forth between file1 and file2. Similarly if I view file1 followed by Untitled<1> then next-file it will flip back and forth between file1 and Untitled<1>. But if I view Untitled<1> followed by Untitled<2>, then next-file will not flip back to Untitled<1> but rather to the previous file viewed before that.

This is inconvenient because I find it useful to paste two pieces of text into new buffers and the flip back and forth to compare them, but the only way to achieve that is to save the buffers as files.

Ian


Ian P

  • Community Member
  • Posts: 59
  • Hero Points: 2
Something else that I've just noticed with this is that I have F7 bound to next-window as I said, and Ctrl-Tab is also bound to next-window as its default binding, but I get different behavior from the two. If I view 4 files sequentially, file1 then file2 then file3 then file4, and then press Ctrl-Tab it will go through this sequence:

  file4, file3, file2, file1

But if I instead use F7 or execute next-window from command line it goes through this sequence (which is actually what I want):

  file4, file3, file4, file3

But neither seems to match what the manual says that smart next file should be doing.

And to add to the mystery, I also just purchased SE 2009 for Linux and used it today for the first time (the above is with the Windows version) and with that Ctrl-Tab, F7 bound to next-file and next-file from command line all give the file4, file3, file2, file1 sequence.

It was a couple of years ago that I configured SE 2007 to act as above so got any ideas of something else I may have set to get the above action from next-file?

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Thanks. We'll look into this and try and fix it for the next release.

We have also found that Smart Next Window may not work correctly on the Gnome desktop if you have the "Highlight the pointer when you press Ctrl" enabled. You can use the search feature on the options screen to find where that is. Even if you're not on Gnome, you might try turning that off.

<Insert joke about "smart" next window and not smart result>

If I've learned anything as a product manager, it's to never use the word "smart" in a feature name. It's just begging for trouble. ;)

David_O

  • Senior Community Member
  • Posts: 152
  • Hero Points: 8
This is a quick note to clarify what Scott mentioned about the "Highlight the pointer when you press Ctrl" option.  This is a gnome desktop option.  You can find it at System -> Preferences -> Mouse.  Then look on the Pointer tab.  Your version of gnome may be different.  This gnome feature does not properly forward the Ctrl event and will affect SlickEdit and other Linux applications.

Ian P

  • Community Member
  • Posts: 59
  • Hero Points: 2
Thanks, I'd been searching through the SlickEdit options for that. My system does have Gnome desktop, but mostly I use se over X-win via SSH so it may or may not apply. But I checked anyway and the Highlight setting is off in Gnome.