Author Topic: Wrong Compiler symbols are displayed when looking for Definition  (Read 3011 times)

crouseb

  • Community Member
  • Posts: 5
  • Hero Points: 0
I have a couple of C/C++ compiler tag files set up in SlickEdit 2008: Cygwin G++ and an embedded ARM compiler.  When I attempt to go to the definition of the symbol in an ARM project, the 'Select Symbol' menu will be displayed showing the symbol definition in the ARM header files and in the Cygwin header files.  I only work with one compiler in a workspace so I only want to have the selected compiler symbols to be displayed.

Is there a way to set up the workspace so that other compiler specific tag files are ignored?

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2920
  • Hero Points: 438
Re: Wrong Compiler symbols are displayed when looking for Definition
« Reply #1 on: February 01, 2010, 03:46:13 pm »
SlickEdit will only select one C/C++ compiler configuration, depending on your project settings or the default compiler setting.  However, if what you really have is a C/C++ compiler configuration (probably the G++ cygwin which is auto-detected), and another Language specific tag file for the ARM compiler, then both would be selected.

In this case, you would need to remove the Language specific tag file and create a specific compiler configuration for the ARM compiler (Document > C/C++ Options > Compiler Properties > New..., and point it at the directories for the ARM compiler.  Then you will need to make sure that your projects point to the ARM compiler rather than the cygwin compiler.

You can also go to Tools > Tag Files and look at what source files are tagged for each of these compilers to be certain that there isn't overlap.  That would be another reason you could be seeing both symbols from the ARM compiler and the Cygwin compiler.

crouseb

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Wrong Compiler symbols are displayed when looking for Definition
« Reply #2 on: February 02, 2010, 09:01:27 pm »
Thanks!  Yes, I had a duplicate C/C++ tag file that contained the Cygwin G++ specific files, when they should have just been in the "C" Compiler Configuration Tag File for the Cygwin compiler.  Deleting it solved the issue.