Author Topic: newline frustration. Please help. This is driving me nuts.  (Read 3924 times)

whitewolf

  • Community Member
  • Posts: 5
  • Hero Points: 0
newline frustration. Please help. This is driving me nuts.
« on: October 12, 2006, 10:34:50 pm »
I upgraded to SlickEdit 10.0.3 (Linux) a while ago.  My previous version of SlickEdit did not display newline characters by default, which is what I want.  I was unhappy to find that my new version did.  I thought that it would be a simple action to turn the display of newline chars off by default.  I cannot for the life of me figure out how to do this.  In the "View" menu you can turn them off for the file you are in, but the next time you open a file the accursed newline chars are back.  I created a button that calls "view-nlchars-toggle" to make turning them off in a file easier, but this is a giant pain because I am always opening multiple files.  Can anyone help me please?

jbezem

  • Community Member
  • Posts: 80
  • Hero Points: 8
Re: newline frustration. Please help. This is driving me nuts.
« Reply #1 on: October 13, 2006, 09:47:07 am »
I don't know from which version you've migrated, but I can see two possible reasons why SE should do this:
- either SE determines the encoding of your files different than you have created them, and decides to use different line endings than the files contain. You could check this in your configuration, look at Tools, Options, File Options, Load-Tab, Encoding. My installation says 'Default', which works for me, YMMV. Also, in the file extension setup, general, there's an entry for setting the encoding for certain file types.
- or the defaults for file creation (Tools, Options, File Options, Save-Tab) are set for a different file-type than you are using.

I didn't test any of these hints, though, so I don't know for sure if they reproduce the exact things you are seeing, but maybe they will help you find your culprit.

One thing you could do (but this doesn't address the problem), is to go to Tools, Options, General, Special-Characters-Tab, and replace the values for End-Of-Line 1 and two with 32 or 0x20, which is a space. The indications will be there, but invisible.

HTH,

Johan

whitewolf

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: newline frustration. Please help. This is driving me nuts.
« Reply #2 on: October 13, 2006, 02:57:42 pm »
I don't think it's a file issue because new files created by me also have the same issue.  Replacing the newlines with a 32 (virtual space) is a good enough solution for me.  Thank you!

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3725
  • Hero Points: 243
Re: newline frustration. Please help. This is driving me nuts.
« Reply #3 on: October 13, 2006, 06:19:33 pm »
I can't tell exactly what your problem is from reading the above.  SlickEdit does not handle mixed EOL files and never has.  Algorithm roughly goes like this:  If the first line of the file ends with a 10 character, then all lines of the file are interpreted as unix line endings.  This means that if there are any 13,10 lines in the file, you will see the 13 character.  Either you can correct your trashed file by using the SlickEdit Save As dialog and select the intended "Line Format" or mess with your view special characters as described above.