Author Topic: Problem with PATH Variable (and others) using Solaris.  (Read 5066 times)

fred75

  • New Community Member
  • Posts: 1
  • Hero Points: 0
Problem with PATH Variable (and others) using Solaris.
« on: October 17, 2006, 12:56:05 pm »
Hello
I'm currently evaluating Slick Edit. I like it. I use it under Solaris. I have configured it to run make in my working
directory where my makefile is.
But it seems like SE doesnt know about my PATH settings. For example the makefile creates directories and failes with mkdir: Command not found.
What's the concept? do I have to reset all my system variable manually? How do I make SE use my .profile?
Thanks for any help.
cheers.
Fred

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4937
  • Hero Points: 404
Re: Problem with PATH Variable (and others) using Solaris.
« Reply #1 on: October 17, 2006, 02:32:13 pm »
SlickEdit is probably using a different shell than your default shell.  Some shells have problems when used in for SlickEdit builds (piped input/output).  It looks like "sh" is used by default on Solaris.  The shell used in the build is in the macro variable "def_process_shell".  Either put your environment setting in ".bashrc" or try changing the def_process_shell macro variable (Macro>Set Macro Variable).

Hope this helps!