Author Topic: Searching not allowed in read only mode???  (Read 4856 times)

Tom

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Searching not allowed in read only mode???
« on: October 19, 2006, 01:04:41 am »
For some reason, when I open a read only file, vslick prohibits me from searching within it. The option is grayed out under the Search dropdown list and Ctrl-F produces the message "This command is not allowed in read only mode"

Version 10.0.3

Other PC's I have vslick installed on are working normally -- search is ok.

Thanks,
Tom

Graeme

  • Senior Community Member
  • Posts: 2366
  • Hero Points: 313
Re: Searching not allowed in read only mode???
« Reply #1 on: October 19, 2006, 10:02:59 am »
Maybe try this.  Type what-is on the slick command line - then press Ctrl-F.  Slick should tell you the name of the command bound to Ctrl-F.  It's probably gui-find.  If so, type the command gui-find on the command line with a read only file and see if you get the error message.  If so, type fp gui-find on the command line - it should open the guifind.e file and show the gui-find function.  Check what name-info attributes are shown - in 10.0.2 I see VSARG2_EDITORCTL as the only attribute.  In version 11.0.2 the attributes are VSARG2_EDITORCTL|VSARG2_READ_ONLY  -  the VSARG2_READ_ONLY attribute means the command is allowed in read-only mode - yet in 10.0.2, gui-find works ok on read-only files for me ??

You could try adding the VSARG2_READ_ONLY attribute and re-compiling the guifind.e module - use "load module" on the macro menu.  Or try slickedit support if you have a maintenance and support contract.

Graeme
« Last Edit: October 19, 2006, 10:04:41 am by Graeme »

Tom

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: Searching not allowed in read only mode???
« Reply #2 on: October 19, 2006, 03:34:16 pm »
You are a genius!!! I'm a novice at vslick but your instructions were clear and the result is success!!! Perhaps when I changed vslick versions something got screwed up, but now it's all good.

Thanks,
Tom

hs2

  • Senior Community Member
  • Posts: 2738
  • Hero Points: 288
Re: Searching not allowed in read only mode???
« Reply #3 on: October 19, 2006, 04:29:10 pm »
As long as you upgrade to v11(.02) things get better (as described by Graeme) ;)
I think this was just a temp. problem maybe only in your version ...

HS2