Author Topic: File extension association problem  (Read 2049 times)

stewartcs

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
File extension association problem
« on: March 25, 2010, 05:59:22 pm »
Hi guys,

I have a problem with associating SE with a file extension. I've tried various ways to associate it like using "open with" and going through the control panel (Folder Options>File Type) and browsing for the executable but it still will not work. I'm using Windows XP Professional and SlickEdit Version 14.0.2.2.

Any ideas what will fix this?

Thanks,

CS

evanratt

  • Senior Community Member
  • Posts: 300
  • Hero Points: 23
Re: File extension association problem
« Reply #1 on: March 25, 2010, 07:44:31 pm »
I associate file types through SlickEdit itself. Go to Options->File Options->Associate File Types, and set up the types you want SE to open. What happens when you try to open a file that you've associated through your method?

jimlangrunner

  • Senior Community Member
  • Posts: 358
  • Hero Points: 30
  • Jim Lang - always a student.
Re: File extension association problem
« Reply #2 on: March 25, 2010, 07:47:26 pm »
I do believe that the OS also has something to do with this.  Under Win7, there's a facility to change default program when right-clicking on a file.  Under XP it was something different when right-clicking, and it was possible via the Explorer->Tools menu to fiddle with extensions and defaults.  What OS?  perhaps I can give you the step-by-step.

Jim

stewartcs

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: File extension association problem
« Reply #3 on: March 26, 2010, 02:21:52 pm »
Hey guys,

Thanks for the responses.

I contacted product support and they sent me this link which helped me solve my problem (most of it anyway).

By choosing the "Advanced" option under the File Types dialog I was able to specify the path correctly to vs.exe. It was definitely an OS problem. The link below gives the details and I basically followed the advice give in it.

http://community.slickedit.com/index.php?topic=742.msg6479#msg6479

One thing I noticed was that I had to use "%1" with the quotes for it to work correctly. Windows XP just uses %1 appended to the end of the path by default (path is separated by a space) and that would not work. It needed the quotes around it to work. Don't know if that is a SE issue or not.

Thanks again...

CS