Author Topic: Core 3.5 and Flash Builder  (Read 3746 times)

acgattegno

  • Guest
Core 3.5 and Flash Builder
« on: March 31, 2010, 05:33:24 am »
Hopefully there's a simple answer.  I just (yesterday) got and started trying to learn Flash Builder.

I've installed Core 3.5 and it is clearly present in the menus.  But neither editor coloring nor my selection of Brief keymap works.

Both work as expected in RSA 7.

Can anyone confirm whether or not they're supposed to work in Flash Builder?  It's hard enough learning a new language/IDE without also not being able to use the keystrokes I've been using for...ever.

Thanks.

acgattegno

  • Guest
Re: Core 3.5 and Flash Builder
« Reply #1 on: March 31, 2010, 05:55:57 am »
A bit more to it:

I have Flash Builder and Cold Fusion Builder integrated.  SE Core works as my editor if I try to edit CF code.  Alas, CF pukes if I try to debug, saying it can only be used with the CFML Editor.

So, in an ideal world, I'd uninstall Core from CF and have it work with Flash Builder.

Any chance of that?

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: Core 3.5 and Flash Builder
« Reply #2 on: April 05, 2010, 09:41:01 pm »
As far as Flash Builder 4 is concerned, I am currently running it with SlickEdit Core 3.5.0 and editing seems to be fine.  It sounds like whatever type of file you are working in either isn't opening with SlickEdit or is not opening in the right language mode.  What file extension are you working with?  What type of files are these?

Make sure that SlickEdit is the default editor for the file extension at Window > Preferences > General > Editors > File Associations.

With the language mode, ActionScript (*.as) should be setup by default, but for MXML files you might have to add the extension.  Go to Window > SlickEdit Preferences > Languages > File Extension Manager, click New..., and associate the extension mxml with XML.

Still having problems?  Show me some screenshots so I can see what is going on, and post the workspace .log file which you can find at WORKSPACEDIR/.metadata/.log.

There is a problem, though, with the Flex support plug-in for Core (found at http://community.slickedit.com/index.php?topic=5622.0) with Flash Builder 4.  Looks like they changed their API, and setting breakpoints in the SlickEdit editor is not working anymore.  I am seeing from my .log file that the create breakpoint method in one of their plug-ins has changed.  Debugging and stepping still works within the SlickEdit editor, and you can set breakpoints via other means in the IDE, but setting them directly in the file (ie. by double-clicking in the left hand margin) looks to be broken.

We will have to build another plug-in to address this issue.

Now, with the problem you are having with Cold Fusion Builder, it sounds like they have hardcoded their editor id in for debugging...which is bad (and wrong), but not unprecedented.  We ran into this exact same issue with PDT (the Eclipse PHP support plug-in) and I had to log a bug with them (https://bugs.eclipse.org/bugs/show_bug.cgi?id=270137) so that they would allow the default editor to be used for debugging instead of hardcoding their editor.  They fixed it in the next release.  Sounds like the same issue, and will likely require the same course of action...so I'm not quite sure what I can say about when this will be rectified :/.

- Ryan