Author Topic: unload-hotfix not working in SlickEdit 2010  (Read 2057 times)

dakdikmen

  • Community Member
  • Posts: 19
  • Hero Points: 0
unload-hotfix not working in SlickEdit 2010
« on: May 04, 2010, 12:48:39 pm »
HI,

Either the unload-hotfix is not working or the "List installed Fixes" is not.  Installed Hotfix rev 1 and then unload-hotfix,  it still shows up on the list installed hot fixes.  I installed the rev 2 host fix and they both show up as installed.

-David

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 322
  • Hero Points: 26
Re: unload-hotfix not working in SlickEdit 2010
« Reply #1 on: May 04, 2010, 03:07:06 pm »
Hi David and All,

Before, when you unloaded a hotfix, we renamed the old ..\My SlickEdit Config\15.0.0\hotfixes\***cumulative.zip to ..\My SlickEdit Config\15.0.0\hotfixes\***cumulative.zip.unloaded so that it would not be "seen" anymore. Moving forward we are putting the Rev # in the actual file name so you will no longer see this behavior if you unload a hotfix.

Exit SlickEdit and rename the older ..\My SlickEdit Config\15.0.0\hotfixes\***cumulative.zip to ..\My SlickEdit Config\15.0.0\hotfixes\***cumulative.zip.unloaded and restart SlickEdit. It should only show the hotfixes that you actually have loaded after this change.

Also, you do not have to actually unload a hotfix; any new "cumulative" hotfix will overwrite the older one. If you simply do not want to see any of the old hot fixes in your Help-->About SlickEdit or your list of "Installed Hotfixes" simply rename any of the older hotfix files to an extension other than .zip

Best,
SlickEdit Support