Author Topic: X11 problem on OSX 10.5.8  (Read 6900 times)

SlimHeilpern

  • Community Member
  • Posts: 18
  • Hero Points: 1
X11 problem on OSX 10.5.8
« on: May 05, 2010, 02:13:02 pm »
Hi -

I have two macs both running 10.5.8. On my main development box, I recently upgraded to SE 1500 and it is currently running great. I was about to upgrade my other box from 1402 to 1500 and just before doing that noticed that I can no longer launch SE on that box because X11 is dying on launch.

- I tried running as another user, same problem.
- I tried removing X11 and reinstalling, removed using the following:
-- sudo rm -rf /Applications/Utilities/X11.app /private/etc/X11 /usr/X11R6 /usr/bin/open-x11 /usr/lib/X11 /Library/Receipts/X11User.pkg
-- and then reinstalled from my Leopard install disk
-- but X11 continued to die on launch

Here's the current error message I'm seeing in the console on launch:

5/5/10 7:05:34 AM [0x0-0x1b01b].org.x.X11[443] dyld: Library not loaded: /usr/X11/lib/libpixman-1.0.dylib
5/5/10 7:05:34 AM [0x0-0x1b01b].org.x.X11[443]   Referenced from: /Applications/Utilities/X11.app/Contents/MacOS/X11.bin
5/5/10 7:05:34 AM [0x0-0x1b01b].org.x.X11[443]   Reason: Incompatible library version: X11.bin requires version 15.0.0 or later, but libpixman-1.0.dylib provides version 13.0.0
5/5/10 7:05:35 AM com.apple.launchd[337] ([0x0-0x1b01b].org.x.X11[443]) Exited abnormally: Trace/BPT trap

Seems like the library that is causing trouble must have been reinstalled by the X11 installer, so I'm at a loss as to what I can possibly due to fix this. And of course, without X11, no SlickEdit, right?

Any help with this would be appreciated -- I'd rather not have to re-install the entire OS to fix this ;-).

Thanks,

- Slim.

SlimHeilpern

  • Community Member
  • Posts: 18
  • Hero Points: 1
Re: X11 problem on OSX 10.5.8
« Reply #1 on: May 05, 2010, 03:22:51 pm »
I finally stumbled onto the answer. Plugging in the error message to google, I discovered that this has something to do with having installed an X11 update at one point (I had done this out of desperation when copy/paste stopped working correctly with the release of SE 1400, and it of course did not fix that problem -- bad move on my part all around).

Apparently this newer version of X11 is broken after an Apple security update is applied (nice!).

So, re-installing the newer version (2.5.0) of X11 fixes the problem. The newer version is available here:

http://xquartz.macosforge.org/trac/wiki/Releases

I assume the X11 installer must touch something outside of the X11 app directory, since otherwise deleting and reinstalling from the Leopard disk would have fixed the problem.

So, I would suggest folks don't install 2.5.0 unless you have a good reason to. Once you install it, it is apparently very difficult to revert. And the X11 site says:

"Mac OS-X Updates (Leopard Only): You will need to re-install this package after future OS, and Security Updates delivered through Apple's Software Update. Additionally, you should reinstall this package after installing XCode."

Reminds me of the common .dll shenanigans I used to have to work around in Windows all the time... ugggh!

- Slim.