Author Topic: Can't get Visual SlickEdit to stop lowercasing my keywords  (Read 2266 times)

sylvia

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Hello,
I just installed SlickEdit Version 14.0.2.2 onto a new machine, and am using it mainly for SQL Server.  My problem is whenever I type

Create

it changes it to

create.

And so on for all the other keywords.  I'd like it to just uppercase the first character, but under Tools, Options, Databases Languages, SQL Server, I can't get any of the changes that I make to actually affect what I see.  I've played with the Keyword Case and Adaptive Formatting.  This wasn't a problem on my old machine, but I don't know what combination of settings I had in place.

Thanks for any help!

Sylvia

jimlangrunner

  • Senior Community Member
  • Posts: 358
  • Hero Points: 30
  • Jim Lang - always a student.
Re: Can't get Visual SlickEdit to stop lowercasing my keywords
« Reply #1 on: May 05, 2010, 07:11:31 pm »
Sylvia

That should work.  (I know, I know).  How about trying with a clean config:
vs -sc (path)
where path is an empty directory will start without any potentially troublesome configuration options. If that works, you've got a bad config, and a place to start.

Jim

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Can't get Visual SlickEdit to stop lowercasing my keywords
« Reply #2 on: May 06, 2010, 02:32:53 pm »
The setting that should control this is under Tools > Options, then expand down to Languages > Database Languages > PL/SQL > Formatting. Select "Capitalize" in "Keyword case". Until you get your setting working correctly, be sure that Adaptive Formatting is off. It will say "Adaptive OFF" if that is the case.

There is a checkbox at the bottom of that group that says "Auto case keywords". Currently, there is a bug in the current version where this is always on regardless of whether the checkbox is checked. The setting for keyword case is used for Syntax Expansion (when you type "when" we insert "when then") as well as for automatically adjusting the case on keywords. Syntax expansion happens when you type a space following a word. Auto case keywords happens once the keyword has been fully typed; no space required.

Setting "Keyword case" to "None" should still do what you want. If for some reason you want the case of your keywords adjusted when you do Syntax Expansion but not when you type a single keyword, you can set the following variable to turn "Auto case keywords" on and off: def_plsql_autocase. Set it to 0 to turn off the automatic adjusting of case.

We'll fix this bug in the next release.


sylvia

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: Can't get Visual SlickEdit to stop lowercasing my keywords
« Reply #3 on: May 07, 2010, 07:20:59 pm »
Thanks for the idea, Jim!  I tried what you said- ran this:

vs -sc C:\Projects\FX\test

It does run me through all the config options with the quick start wizard at that point.  

But then  it's just upper-casing ALL my keywords.

Anyway - I did more playing around, and it looked like by default it using the PL/SQL setting for sql files, not SQL Server.  So I switched
those around, and now it's doing what I want.

thanks again!