Author Topic: Crash on "Close Workspace" in SE 14.0.2.2 with all hotfixes applied  (Read 4024 times)

dgregryc

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
I have a workspace loaded that contains about 23 open files.  I'm using Perforce Integration on Windows 7.

If I select Project/Close workspace, I will crash 100% of the time.  I have exported a dump if this is required - not sure how to get it to you for analysis if that is required.

--

Separate issue, but less important - I have turned off XML validation Via Tools/Options/Languages/XML-Text Languages/XML/Formatting/Auto validate on open (cleared, not set).  I am still getting "Error processing schema for file..." dialogs when I load certain XML files.  (Which are formed correctly by the way).  Any idea how to silence this error?

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
I'll have someone else address the Perforce issue. That may be a known problem we are having with their latest version.

As for the schema issue, SlickEdit uses the schema for validation and for color coding. So even if you turn off validation, SlickEdit will attempt to find the schema. If it can't locate it for any reason, you will get that error. To prevent the schema from being loaded, you can add the extension of the file specifying the DTD/schema to the def_xml_no_schema_list variable. Use the SlickEdit command line (press ESC in most emulations) and type "set-var" followed by Enter. type the name of the variable, in this case "def_xml_no_schema_list" and press Enter. SlickEdit will display the current contents of the variable and allow you to modify it.

This will suppress the loading of schema files for all files with the specified extension, which will prevent you from being able to validate files of that extension as well. If, you are having trouble loading a single schema or a few schemas, you can define a local directory to hold that schema. To do that, select Tools → Options → Network & Internet Options → URL Mappings from the main menu. Then add the URL for this DTD/schema and specify a directory where that file can be found.

We're looking at adding a new Notification icon for errors and warnings. Dialogs like this one will be displayed as pop-ups using that system, so they will be much less bothersome in the future.




Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2744
  • Hero Points: 145
dgregryc: Please PM me an email address so I can send you a new vc.e macro and vsscc.dll.

dgregryc

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
re: XML validation.

I've done set-var<enter> def_xml_no_schema_list<enter> .config<enter>.

It still tries to validate the schema.

I would love to validate the XML for these files properly (they are Cruise Control .NET config files).  And I'd be willing to copy the files locally. However, I have no idea where to find the schema that it is trying to validate against.

"urn:ccnet.config.builder" is what it is claiming that it cannot find.  Googling just isn't helping me solve this one.

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Can you post the XML file? If it contains something private, can you post the header? Maybe we can help figure out why it's trying to locate that urn thing.

I assume the extension of the file is ".config". If so, you'll need to define a new extension for your setting in XML to apply to this file. Open Tools > Options > Languages > File Extension Manager. Click the "New" button, enter "config" in the "Extension" field and select "XML" in the "Language" field. Now the setting for auto-validating should work on this file.

dgregryc

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
FYI, I already had the extension in the Extension Manager, and it was assigned as XML language.

Here's one of the .config files:

Code: [Select]
<cb:config-template xmlns:cb="urn:ccnet.config.builder">
<cb:define p4_client="foo_bar"/>
<cb:define p4_user="foo"/>
<cb:define p4_pass="pwd"/>
<cb:define p4_port="address:6666"/>
</cb:config-template>

Really quite simple.  I'm trying to specify as namespace as required by Cruise Control .NET.   XML validation isn't picking it up because it doesn't know where to find that namespace.