Author Topic: SlickEdit 15.0.0.5 react so slow when switching with other application window  (Read 23378 times)

abcd

  • Guest
When switched from other application window, SlickEdit 15.0.0.5 need wait some seconds to be ready to be used: for example, I switched from msn messager window to SlickEdit project, the messager window still stay upon the window of SlickEdit, and there was no reaction when I move cursor or move mice, the SlickEdit's toolbar displays as whole white as it was idle.

I use it on Windows XP, and enabled the "Symbol coloring" function. The attach is my Context Tagging option.
What's the reason and how to fix it ?

Thanks a lot!

« Last Edit: June 04, 2010, 08:39:38 am by abcd »

abcd

  • Guest
May I adapt the display thread to a higher priority than the job's priority that it does when it be switched to be non-active?

The speed of SlickEdit 15.0.0.5 resume to working status is so slow that I can't tolerate it, so this problem make me think that even source insight is better than it even it's free.

abcd

  • Guest
 >:( >:(
Just A minutes ago, I tested it's performance when I disabled Symbol coloring, still slow; then I closed all the opening file, it reacted right now when I switched it with other application.

So, Is there some performance problem with SlickEdit when open more than 15 files? And is there some options to adapt it to make it resume faster when switch it from inactive to active state?

But when I have posted this message, I return to SlickEdit, I found it become unreponse until 1-2 minutes later: please note that I just open one file. So, there's some problem with mine SlickEdit 15.0.0.5 surely. Who can tell me how to resolve it??

 
Thanks and Regards!

« Last Edit: June 04, 2010, 09:17:31 am by abcd »

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
I routinely have several files open and switch between apps with very little delay. On occasion, I might see a delay as much as 15 seconds, but that's rare. I am also on Windows XP.

Try turning auto reload off. This setting is at Tools > Options, then navigate down to File Options > Load. Set "Auto reload" to "False". When that is on, SlickEdit checks to see if the open files have been modified when you switch applications.

Are the files you are editing stored on your machine locally or on a network resource? Also, can you post your Help > About SlickEdit information?

What about when you switch away and switch back with no files open? Is that also slow? Try closing your workspace, thens switch away and switch back. Lastly, try starting with a new, default config. You can do this by using the "-sc" option on the command line, either by typing the command directly or editing the "Target" field for a shortcut.  Use something like "vs -sc c:\temp". It needs to point somewhere you don't already have a config so that a new, default config will be created. After doing that, don't tag any files. Try to switch away and then back. Was that slow? Then try opening one of the files you've been editing--not the workspace--just the file. Switch away and then back. Was that slow? Now try opening the workspace and repeat the test.

Sorry for the permutations, but this will help us understand where the problem might be.

abcd

  • Guest
I routinely have several files open and switch between apps with very little delay. On occasion, I might see a delay as much as 15 seconds, but that's rare. I am also on Windows XP.

Try turning auto reload off. This setting is at Tools > Options, then navigate down to File Options > Load. Set "Auto reload" to "False". When that is on, SlickEdit checks to see if the open files have been modified when you switch applications.

Are the files you are editing stored on your machine locally or on a network resource? Also, can you post your Help > About SlickEdit information?

What about when you switch away and switch back with no files open? Is that also slow? Try closing your workspace, thens switch away and switch back. Lastly, try starting with a new, default config. You can do this by using the "-sc" option on the command line, either by typing the command directly or editing the "Target" field for a shortcut.  Use something like "vs -sc c:\temp". It needs to point somewhere you don't already have a config so that a new, default config will be created. After doing that, don't tag any files. Try to switch away and then back. Was that slow? Then try opening one of the files you've been editing--not the workspace--just the file. Switch away and then back. Was that slow? Now try opening the workspace and repeat the test.

Sorry for the permutations, but this will help us understand where the problem might be.
hi, ScottW, my source files are on the network, but my workspace files are on local.I have tried to open a 100% local project, it react quickly.

And I have test your method as run using cmd "vs -sc c:\temp", it's fast too.

And I have test your advice to set "Auto load" to false, it's effective. I can see the big distance between this option be true and false. Perhaps it's where's my problem on, for my project source file is on network.

Thank you very much for your very nice and professional help!

-------------------------------------------------------------------
There's+ still a problem, just a minutes ago, after I read some web page, I switched to SlickEdit, it display as a whole white until some seconds later. I tried it several times, sometime it displayed "no response" on the title bar and other region displayed as a whole white. Could you tell me how to resolve it?

Thanks!

« Last Edit: June 07, 2010, 11:58:33 am by abcd »

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
OK, let's summarize where we are:
  • workspace files are local
  • source files are remote
  • Symbol Coloring is on
  • auto-reload is off

When you switch back to SlickEdit, is the active buffer particularly large? Does the problem still occur when a smaller file is in the active buffer? When you switch applications, does the vs.exe process use a lot of CPU? Does your disk like blink a lot. We need to know where the latency is occurring.

Try turning Symbol Coloring off to see if that avoids the delay. If so, then maybe we can get to acceptable performance through changing the settings.

abcd

  • Guest
OK, let's summarize where we are:
  • workspace files are local
  • source files are remote
  • Symbol Coloring is on
  • auto-reload is off

When you switch back to SlickEdit, is the active buffer particularly large? Does the problem still occur when a smaller file is in the active buffer? When you switch applications, does the vs.exe process use a lot of CPU? Does your disk like blink a lot. We need to know where the latency is occurring.

Try turning Symbol Coloring off to see if that avoids the delay. If so, then maybe we can get to acceptable performance through changing the settings.
How to see the active buffer SlickEdit using?I have open about 20 files, but most file are less of 1000 lines. The no response situation happened too when small file is open.
Today, the no response situation is being worse, it happens frequently so that each time I need wait about a minutes to continue when switch back to SlickEdit.
My CPU is core-dual, when SlickEdit have no response, the CPU occupy rate is less than 20%, and there are  larger than 1G physical memory available.

because using source-insight, it reacts quickly, so I think it maybe a performance problem of SlickEdit 15.0.0 .

First of all, Could you give me a temp resolve method to make it works quickly?
Thank you very much!



abcd

  • Guest
Hi, today I found a important phenomenon: I opened slickedit, but when I switch to it, the bottom tool windows(reference, preview, search.. etc) display previous windows color; I closed the workspace, and I switched slickedit with other application, the situation continued, what's more, when I clicked the tool windows' auto hide button(reference, preview, search.. etc), SlickEdit can't draw these windows correctly.
The attachments are the slickedit picture.

Another phenomenon is that when I restart vs, with no project load, it works fine... oh, my god!what had happened?

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
The active buffer is the one that you are editing or has focus. It's the visible editing window if you only have one window visible.

I can't give you a workaround because we don't know what's going on here. Based on what you've told me, it sounds like a latency problem accessing the remote files. But shutting off auto-reload should have addressed that.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2375
  • Hero Points: 133
abcd:

Have you restarted your editor recently?

If you go to Document>List Open Buffers, are there only files you expect to be there?

abcd

  • Guest
abcd:

Have you restarted your editor recently?

If you go to Document>List Open Buffers, are there only files you expect to be there?
Yes, everyday I restart edit about 3-10 times.
In the List Open Buffers, those files are those files opened last time, the number is about 20 - 30.

abcd

  • Guest
The active buffer is the one that you are editing or has focus. It's the visible editing window if you only have one window visible.

I can't give you a workaround because we don't know what's going on here. Based on what you've told me, it sounds like a latency problem accessing the remote files. But shutting off auto-reload should have addressed that.

Yes, if it's because of opening Network files, the auto-reload should solve it. But it still reacted slowly. It
s strange.
This problem is not so significant on previous SlickEdit version such as 14.0.0, I even can't feel it.
Perhaps some modifications on the 15.0.0 version produce this problem.
« Last Edit: June 10, 2010, 01:48:40 am by abcd »

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2375
  • Hero Points: 133
If you go to Macro>Set Macro Variable and select "def_actapp", what is the value?

abcd

  • Guest
The value is 16.

vivitron

  • Senior Community Member
  • Posts: 162
  • Hero Points: 10
Not sure if this is related, but thought I would put it out there. I personally have noticed something odd when I have a large file open (1800 lines)...  Whenever I switch back to SE after using another application, there is a good 3-5 second delay before SE is ready to roll again.  Nothing fancy here, everything is on a local disk.  It does not happen with smaller files to the same degree.  Sometimes the screen "appears" instantly, but you cannot move the cursor for several seconds.

If I switch between other files and a large file within SE, there is no delay at all.

So far, I've tried the following:
  • Disabled Symbol Coloring (no difference)
  • Disabled Auto Reload (no difference)
  • Set Load Entire File = False ( this seems to help a bit, but problem remains )

About:
Code: [Select]
SlickEdit Version 15.0.0.5

Serial number: WB936535
Licensed number of users: Single user
License file: C:\ProgramData\slickedit\15\slickedit.lic

Build Date: April 26, 2010
Emulation: CUA

OS: Windows 7
OS Version: 6.01.7600 
Memory: 45% Load, 828MB/4194MB Physical, 294MB/2097MB Virtual
Shell Info: C:\Windows\system32\cmd.exe /q
Screen Size: 1440 x 900

Project Type:
Language: .cs (C#)

Installation Directory: C:\Program Files (x86)\SlickEditV15.0.0\ (non-removable drive,NTFS,29676MB free)
Configuration Directory: Z:\vivitron\Documents\My SlickEdit Config\15.0.0\ (non-removable drive,NTFS,80016MB free)

Hotfixes:
Z:\vivitron\Documents\My SlickEdit Config\15.0.0\hotfixes\hotfix_se1500_2_cumulative.zip (Revision: 2)
Z:\vivitron\Documents\My SlickEdit Config\15.0.0\hotfixes\hotfix_se1500_3_cumulative.zip (Revision: 3)
Z:\vivitron\Documents\My SlickEdit Config\15.0.0\hotfixes\hotfix_se1500_5_cumulative.zip (Revision: 5)
Z:\vivitron\Documents\My SlickEdit Config\15.0.0\hotfixes\hotfix_se1500_cumulative.zip (Revision: 1)