Author Topic: Fonts: where does VSE 10 look for them?  (Read 4410 times)

tinker123

  • Community Member
  • Posts: 90
  • Hero Points: 3
Fonts: where does VSE 10 look for them?
« on: October 30, 2006, 06:31:52 pm »
Hi;

I recently upgraded my home PC to the latest ( edgy ) version of Ubuntu linux.  It seems everywhere I go in my desktop now I have ttf fonts.  This usually looks lousy in linux, but I have to admit it looks good.

My problem is their one place where it does not look good and that is in my editor ( commercial linux app ) Visual Slick Edit 10

I'm guessing there is a default font directory that was changed in the upgrade process. 

Does anyone know what directory VSE 10 looks for fonts in  so I can find some way to point VSE to it?

Thanks

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4896
  • Hero Points: 399
Re: Fonts: where does VSE 10 look for them?
« Reply #1 on: November 01, 2006, 09:18:51 pm »
SlickEdit V10 does not have XFT support (needed for TTF and anti-aliasing).  You need V11.

mgweeks

  • Community Member
  • Posts: 24
  • Hero Points: 1
Re: Fonts: where does VSE 10 look for them?
« Reply #2 on: November 01, 2006, 11:20:39 pm »
Well, I have kind of a related question. I have 11.0.2 with the latest patches installed. I upgraded to ubuntu edgy and most of slickedit looks fine. The only problem is that when I go into the subversion history dialog, it displays with some small font that looks horrible. I've looked through all the preferences/fonts and can't fine anything related to the version control interface. Where can I go to modify the font that it is using?

tinker123

  • Community Member
  • Posts: 90
  • Hero Points: 3
Re: Fonts: where does VSE 10 look for them?
« Reply #3 on: November 04, 2006, 12:10:20 am »
I think I found the answer to my question.

In the upgrade to Ubuntu 6.10 Edgy somebody goofed up in the font paths listed in
/etc/X11/xorg.conf

Instead of starting off
/usr/share/fonts/X11/

All but one of the font paths starts off as
/usr/share/X11/fonts

I switched "X11/fonts"  to "fonts/X11"  rebooted.  VSE looks right again and my fonts in other places are the way they should be.

To edit /etc/X11/xorg.conf you need to be root which you can do in Ubuntu with
> sudo bash

from there you can use a CLI editor or

> gedit xorg.conf

Good Luck!

Steve




Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 4896
  • Hero Points: 399
Re: Fonts: where does VSE 10 look for them?
« Reply #4 on: November 06, 2006, 07:31:52 pm »
Isn't it obvious (not!), you need to change the HTML Proportional font :-)  Set the "Dialog font" if you want to change the font for the tree control as well.

mgweeks

  • Community Member
  • Posts: 24
  • Hero Points: 1
Re: Fonts: where does VSE 10 look for them?
« Reply #5 on: November 06, 2006, 09:41:40 pm »
Darn, now why didn't I think of that :-[  It's just so obvious(not)!