Author Topic: Slickedit 15.0.0.6 Crash on Startup  (Read 14050 times)

mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
Slickedit 15.0.0.6 Crash on Startup
« on: June 23, 2010, 03:04:55 pm »
SlickEdit is crashing on startup (after reboot).

AppName:  vs.exe
AppVer:  15.0.0.6
ModName:  vsapi.dll
ModVer:  15.0.0.6
Offset:  00045795

"vs -sc c:\temp" works.

What additional information would you like?

The windows error report file is attached.



Sandra

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 754
  • Hero Points: 36
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #1 on: June 23, 2010, 03:39:29 pm »
Are you up to date on your hotfixes?  I think the latest, revision 7, was released last week.  This problem looks like something that was addressed in the most recent revision.

mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #2 on: June 23, 2010, 04:13:26 pm »
I believe that I did, but when I run "-sc c:\temp" Help->Product Updates->List Installed Fixes doesn't show any hot fixes installed.  If I then install hotfix 15.0.0.7 while running "-sc c:\temp" directory SE still crashes if I don't use "-sc c:\temp".

After applying the hot fixes Help->About Slickedit still shows version 15.0.0.6.


mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #3 on: June 23, 2010, 04:23:32 pm »
It is something in the vslick.sta file.

Is there any way to single step the loading of the vslick.sta file to see where it crashes?

Sandra

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 754
  • Hero Points: 36
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #4 on: June 23, 2010, 05:43:06 pm »
When you apply a hotfix, it only applies it to the configuration that you were on when you applied it.  So the hotfixes you installed will be in your (now crashy) configuration, but not in the temp one you've been running.  Also, the application version will still say 15.0.0.6, no matter how many hotfixes you apply to it.

You can check whether you have the latest hotfix by going to your crashy configuration and looking in the hotfixes subdirectory.  Along with a bunch of macro files, you'll find the zip files themselves.  You can tell that you got the latest one if you see a file named hotfix_se1500_7_cumulative.zip.

Here's something to try.  Open up your vrestore.slk file, which should be in your crashy config directory.  Look for a line that begins with "PIP:".  Delete that line, save the file, and see if you can run the application.

Thanks!

mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #5 on: June 23, 2010, 05:50:33 pm »
Thank you for the help.

Hot Fix 7 has was not installed in the crashy configuration.

Removing the pip: line from the vrestore.slk file did not fix things.

Renaming the vrestore.slk file to vrestore.sav also did not fix things.

Any other ideas???

Thanks again....

mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #6 on: June 23, 2010, 05:54:58 pm »
I renamed the vslick.sta to vslick.sav.  Installed hotfix 7 and then renamed it back.  This did not fix the problem.

Is there anything that I can do to help debug this?

Thanks...

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 340
  • Hero Points: 26
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #7 on: June 23, 2010, 07:26:53 pm »
Hi there.

Let's try this from a different tack.  Forget all the -sc's and the renaming of the vrestore.slk file.

I am guessing that you had SlickEdit 14022, the 1500 beta, 15005, and or 15006 installed at one point correct? (Some or all mentioned.)

--Did you just install this version of SlickEdit (15.0.0.6) or did you install it some time ago and this has just started happening?

--Which version did you have installed before?

--Which numbered folders do you have in your My SlickEdit Config directory? (Besides the presumed \Documents\My SlickEdit Config\15.0.0)

And now to the fix. What happens if you rename ONLY the vslick.sta file in ..\My SlickEdit Config\15.0.0 and then start SlickEdit? (I see that you renamed it below and if you were able to load hotfix rev7 that tells me that SE 15.0.0.6 starts correctly and that it only breaks when you install the hotfix?)

Best,
SlickEdit Support

mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #8 on: June 23, 2010, 07:31:21 pm »
I have 14.0.1, 14.02 and 15.0.0 directories in the "My SlickEdit Config" directory.

Everything was working fine until this morning.  I had not installed hot fix 7.

To install hot fix 7 I renamed the vslick.sta file and then installed hot fix 7 and then renamed the vslick.sta file back.  This did not fix the issue.




mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #9 on: June 24, 2010, 02:32:58 pm »
Is there any way to merge the "crashy" vslick.sta into my current vslick.sta so that I can recover my configuration?

Thanks...

Graeme

  • Senior Community Member
  • Posts: 2561
  • Hero Points: 330
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #10 on: June 25, 2010, 01:33:04 pm »
Is there any way to merge the "crashy" vslick.sta into my current vslick.sta so that I can recover my configuration?

Thanks...

I'm sure slickedit support will tell you this, or something like it

1. with slickedit closed, backup your entire configuration folder before you do anything else
2. rename vslick.sta to e.g. vslick.sta.crash
3. start slickedit.  Most, if not all of your configuration should be still there as it is recovered from files such as vusrdefs.e in your configuration folder

4. if your configuration settings look ok, export your entire configuration using tools -> options  -> export  -> export/import and save it somewhere

vslick.sta is a binary file containing "p-code" (compiled slick C macro code) that is interpreted at runtime (and somehow seems to still run quite fast), plus a bunch of other stuff, including your configuration settings in binary form.  If vslick.sta becomes corrupted, renaming it or deleting it can fix the problem.  If there's something in your configuration that caused the crash, you could try selectively importing it from your exported configuration, if you succeed in exporting it.

When you load a hotfix (or any slick C file), the compiled source code gets stored in vslick.sta so renaming vslick.sta, then loading the hotfix, then renaming vslick.sta back doesn't actually load the hotfix because you threw away the vslick.sta file that it got loaded into, even though your hotfix folder shows it as being loaded.

Also, at tools -> options -> application options -> exit, I have the "save configuration" option set to "always prompt" so that if something goes wrong, I have the option of not generating a new vslick.sta file when slick closes.

Graeme

mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #11 on: June 25, 2010, 01:52:18 pm »
Thanks.  I have basically done exactly that.  Unfortunately, There is no way to selectively load the vslick.sta file so there is no way to recover all but the bad section of the .sta file.  In the future I will backup (export) my configuration so that if I encounter this problem again, I will not have to remember everything that I configured.

This might be a good future feature request.  Either a way to selectively import a vslick.sta or selectively load it on startup.

mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
It happened again today while running
« Reply #12 on: June 30, 2010, 06:17:45 pm »
I was eating lunch today (30-Jun-2010) with SlickEdit open and all of a sudden the dreaded "SlickEdit has encountered a problem and needs to close.  We are sorry for the inconvenience." dialog box popped up on the screen.  And when I tried to restart SlickEdit I started getting the crash on every startup.

I have attached the vslick.sta file that is causing the problem this time.  I have also attached the Windows Error Report

After renaming the offending vslick.sta file to vslick.sav1 and restarting SlickEdit I get the following error dialog box:

There were errors loading the following user modules (from dev_macfiles).

CONFLICT:                    C:\Program Files\SlickeditV15.0.6\macros\asm.ex


I am running with the latest (15-Jun-2010) hotfix.

Any new ideas or a way to single step the startup procedure to help debug this?

Please help...




mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #13 on: June 30, 2010, 06:24:30 pm »
After clearing the SlickEdit asm.ex conflict dialog box SlickEdit again errors out with the standard windows application error.  But when the error dialog is cleared SlickEdit does not exit.  The process needs to be killed manually from the task manager or the task bar.

Currently this is happening without a vslick.sta or vslick.idx in the main slickedit path.

vs -sc c:\temp works.

mkatz

  • Community Member
  • Posts: 93
  • Hero Points: 2
Re: Slickedit 15.0.0.6 Crash on Startup
« Reply #14 on: June 30, 2010, 06:28:08 pm »
I am still getting the asm.ex conflict error even after renaming asm.ex and asm.e to other names.

Rebooting now...  I will continue to report information as I continue.

Thanks for the help....