Author Topic: SlickEdit 2010 PHP -- Error starting debugger: version not supported?  (Read 5198 times)

HorizonX

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
I get the following error messages when trying to debug my PHP applications:

Error starting debugger: version not supported
Project command failed to run.

It launches in whatever browser I configure just like it's supposed to and XDebug does try to open a debug session, but for some reason the connection just doesn't work.  I know XDebug is installed and working properly, but I'm not 100% sure that I have everything configured correctly.

I'm running the server locally --

OS: Windows XP SP3
XAMPP Lite 1.7.3
PHP 5.3.1
XDebug: php_xdebug-2.1.0RC1-5.3-vc6.dll

Code: [Select]
phpinfo()
PHP Version => 5.3.1

System => Windows NT HX4 5.1 build 2600 (Windows XP Professional Service Pack 3) i586
Build Date => Nov 20 2009 17:20:57
Compiler => MSVC6 (Visual C++ 6.0)
Architecture => x86
Configure Command => cscript /nologo configure.js "--enable-snapshot-build"
Server API => Command Line Interface
Virtual Directory Support => enabled
Configuration File (php.ini) Path => 
Loaded Configuration File => C:\XAMPP\xampplite\php\php.ini
Scan this dir for additional .ini files => (none)
Additional .ini files parsed => (none)
PHP API => 20090626
PHP Extension => 20090626
Zend Extension => 220090626
Zend Extension Build => API220090626,TS,VC6
PHP Extension Build => API20090626,TS,VC6
Debug Build => no
Thread Safety => enabled
Zend Memory Manager => enabled
Zend Multibyte Support => disabled
IPv6 Support => enabled
...
This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies
    with Xdebug v2.1.0rc1, Copyright (c) 2002-2010, by Derick Rethans

Configuration
...
xdebug

xdebug support => enabled
Version => 2.1.0rc1

Supported protocols => Revision
DBGp - Common DeBuGger Protocol => $Revision: 1.145 $

Directive => Local Value => Master Value
xdebug.auto_trace => Off => Off
xdebug.collect_assignments => Off => Off
xdebug.collect_includes => On => On
xdebug.collect_params => 0 => 0
xdebug.collect_return => Off => Off
xdebug.collect_vars => Off => Off
xdebug.default_enable => On => On
xdebug.dump.COOKIE => no value => no value
xdebug.dump.ENV => no value => no value
xdebug.dump.FILES => no value => no value
xdebug.dump.GET => no value => no value
xdebug.dump.POST => no value => no value
xdebug.dump.REQUEST => no value => no value
xdebug.dump.SERVER => no value => no value
xdebug.dump.SESSION => no value => no value
xdebug.dump_globals => On => On
xdebug.dump_once => On => On
xdebug.dump_undefined => Off => Off
xdebug.extended_info => On => On
xdebug.file_link_format => no value => no value
xdebug.idekey => HorizonX => slickedit
xdebug.manual_url => http://www.php.net => http://www.php.net
xdebug.max_nesting_level => 100 => 100
xdebug.overload_var_dump => On => On
xdebug.profiler_aggregate => Off => Off
xdebug.profiler_append => Off => Off
xdebug.profiler_enable => Off => Off
xdebug.profiler_enable_trigger => Off => Off
xdebug.profiler_output_dir => C:\XAMPP\xampplite\tmp => C:\XAMPP\xampplite\tmp
xdebug.profiler_output_name => xdebug_profile.%p => xdebug_profile.%p
xdebug.remote_autostart => Off => Off
xdebug.remote_connect_back => Off => Off
xdebug.remote_cookie_expire_time => 3600 => 3600
xdebug.remote_enable => On => On
xdebug.remote_handler => dbgp => dbgp
xdebug.remote_host => localhost => localhost
xdebug.remote_log => no value => no value
xdebug.remote_mode => req => req
xdebug.remote_port => 9000 => 9000
xdebug.scream => Off => Off
xdebug.show_exception_trace => Off => Off
xdebug.show_local_vars => Off => Off
xdebug.show_mem_delta => Off => Off
xdebug.trace_format => 0 => 0
xdebug.trace_options => 0 => 0
xdebug.trace_output_dir => C:\XAMPP\xampplite\tmp => C:\XAMPP\xampplite\tmp
xdebug.trace_output_name => trace.%c => trace.%c
xdebug.var_display_max_children => 128 => 128
xdebug.var_display_max_data => 512 => 512
xdebug.var_display_max_depth => 3 => 3
...

Any ideas?

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 767
  • Hero Points: 50
Well, we accidentally on purpose disallowed versions >=2.1.

We have not tested on this release candidate of Xdebug. If you (and anybody else who likes) would like to be a guinea pig and try out the attached vsdebug.dll, then:

1. Make sure you are running SlickEdit 15.0.0.6 (the latest as of this post). Get your version from Help>Program Information.

2. Exit SlickEdit.

3. Rename slickedit/win/vsdebug.dll and replace with the attached.

Please report any success or failure you have.

--rodney

HorizonX

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Thanks, seems to be working like a champ!  :D

Tim Kemp

  • Senior Community Member
  • Posts: 537
  • Hero Points: 91
I also got bitten by this.  If you are keeping track, the new version of vsdebug.dll is working fine for me too.

- Tim

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 767
  • Hero Points: 50
This fix will be included in 15.0.1 which is due out shortly.

--rodney