Author Topic: Help: how to expand tabs  (Read 3407 times)

andredz

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Help: how to expand tabs
« on: November 02, 2006, 10:56:16 pm »
I've been trying to load asm (.S) files, but the tab chars always show as special chars (square box).
I don't see any problem loading makefile.
I have tried to set the following:

Tools -> Options -> File Options -> Load -> Expand tabs to spaces

But this is not what I want. I want the real tab for tabs.

I had SE v10 and just installed SE v11.
I didn't have any problems with SE v8.

Can anybody help? which options do I have to set?

Thank you,
- Andreas



Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2780
  • Hero Points: 421
Re: Help: how to expand tabs
« Reply #1 on: November 03, 2006, 06:08:28 am »
Three things you can look into:

1) View > Tab Chars, turn this off if you don't want to see tabs as special chars

2) Tools > Options > General, Special Characters tab.  Here you can configure what character gets displayed for tabs when View > Tab Chars is on.

3) Tools > Options > Color.  Here you can configure the color you want special characters to be displayed using.

Graeme

  • Senior Community Member
  • Posts: 2357
  • Hero Points: 309
Re: Help: how to expand tabs
« Reply #2 on: November 03, 2006, 10:03:36 am »
In case Denis's suggestions don't help -

I recall that someone posted with this problem in Slick V9 two years ago
http://www.lazyhacker.com/slickedit/forum/viewtopic.php?t=219&highlight=

In slick V11, creating a .s file and enabling entry of hard tabs into the source file, then typing a tab, tabs show as a square block (with view tab chars turned off).  With view tab chars turned on, they show as square blocks in a lighter shade of grey.  I get the feeling from Denis's comments that this is not the intended behaviour.

If you change the representation of a tab char to a space, you'll hide the square box but you won't be able to see tabs as special chars without changing the representation again.

From what I posted on lazyhacker it looks like a possible way to get rid of the square blocks is to go to Document on the main menu, then "Select mode" and choose "Intel assembly".  I dunno what ramifications doing this has but the square blocks seem to go away.

Graeme
« Last Edit: November 03, 2006, 10:38:21 am by Graeme »

andredz

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: Help: how to expand tabs
« Reply #3 on: November 03, 2006, 06:30:50 pm »
Thank you,

your link to the lazyhacker is really help.

- Andreas