Author Topic: SlickEdit 15.0.1.3 and JUnit 4.8.2  (Read 5116 times)

bobfalk

  • Community Member
  • Posts: 6
  • Hero Points: 0
SlickEdit 15.0.1.3 and JUnit 4.8.2
« on: August 19, 2010, 12:19:00 am »
I'm just starting to use SlickEdit and am having trouble executing a JUnit test case.  I get the following error:
BEGIN_TESTING
TEST !HelloWorldTest
JUnit version 4.8.2
Exception in thread "main" java.lang.NoSuchMethodError: org.junit.runner.Request.classes(Ljava/lang/String;[Ljava/lang/Class;)Lorg/junit/runner/Request;
   at org.junit.runner.JUnitCore.run(JUnitCore.java:115)
   at org.junit.runner.JUnitCore.runMain(JUnitCore.java:93)
   at org.junit.runner.JUnitCore.main(JUnitCore.java:44)
ENDTEST
END_TESTING
The batch file cannot be found.

Scanning through the help text, the manual, and the forum have not turned up any solutions. Does anyone know what I am overlooking? Thanks! --Bob

bobfalk

  • Community Member
  • Posts: 6
  • Hero Points: 0
Re: JUnit 4.8.2 works fine in Eclipse, not in SlickEdit
« Reply #1 on: August 19, 2010, 05:08:51 pm »
I can run this sample unit test in Eclipse just fine, but it won't run at all in SlickEdit.  I must be missing something.  Some help would be appreciated.  Thanks. --Bob

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: SlickEdit 15.0.1.3 and JUnit 4.8.2
« Reply #2 on: August 19, 2010, 06:37:31 pm »
It might be that we need to update our support for JUnit. My tests using 4.4 work, but my tests with 4.6 give the same errors you are reporting.

bobfalk

  • Community Member
  • Posts: 6
  • Hero Points: 0
Re: SlickEdit 15.0.1.3 and JUnit 4.8.2
« Reply #3 on: August 19, 2010, 06:52:24 pm »
Perhaps I can copy the test runner from 4.4 as a separate jar and add it to the project's path.  I think later versions of JUnit have just continued to use an older test runner.  I'll have to check into it on the JUnit site.  Thanks for trying it out.  I appreciate it.  --Bob

bobfalk

  • Community Member
  • Posts: 6
  • Hero Points: 0
Re: SlickEdit 15.0.1.3 and JUnit 4.8.2
« Reply #4 on: August 20, 2010, 12:09:15 am »
Scott,  I've done some digging and see that JUnit changed the pattern for executing test cases in JUnit 4.5.  I have not yet found a way to make SlickEdit happy with it, however. --Bob

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: SlickEdit 15.0.1.3 and JUnit 4.8.2
« Reply #5 on: August 20, 2010, 02:03:57 pm »
I thought that might be the case. We'll look into updating the JUnit support for v16. In the meantime, let us know if you come up with any workarounds.

bobfalk

  • Community Member
  • Posts: 6
  • Hero Points: 0
Re: SlickEdit 15.0.1.3 and JUnit 4.8.2
« Reply #6 on: August 20, 2010, 02:34:08 pm »
Will do. Thanks! --Bob