Author Topic: Auto-complete files recently added to the workspace (Slickedit 15.0.1.3)  (Read 2570 times)

colonel_coder

  • Community Member
  • Posts: 49
  • Hero Points: 1
I am having a problem with auto-complete when I add a new C++ class to my workspace.

I have several separate projects in one workspace.  I have a "common" project where I add C++ files that are shared between the other projects.  When I add a new pair of <object>.cpp and <object>.h files to the "common" project, the files do not appear to get tagged properly.

The way this manifests itself is that auto-complete does not work for methods of an instance of the new class.  Also, searching for references to a method of the new class does not show the references that I have added to files in other projects in the workspace.

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Auto-complete files recently added to the workspace (Slickedit 15.0.1.3)
« Reply #1 on: September 22, 2010, 02:32:03 pm »
The first thing is to make sure the newly added files are in your workspace tag file.
1) Select Tools > Tag Files to open the "Context Tagging - Tag Files" dialog.
2) Then expand the "Workspace Tag file" node.
3) Click on the tag file listed in this node.
4) Check that the newly added files are listed in the right-hand pane.

If the files are listed, click the "Rebuild Tag File" button and see if that fixes the problem. If it does, then we need to figure out why your tag file is not being updated when you add files to the project.

colonel_coder

  • Community Member
  • Posts: 49
  • Hero Points: 1
Re: Auto-complete files recently added to the workspace (Slickedit 15.0.1.3)
« Reply #2 on: September 23, 2010, 02:59:42 pm »
If the files are listed, click the "Rebuild Tag File" button and see if that fixes the problem.

I have tried that many times, but it does not seem to have any effect.  I will add that the name of the class is Timer and the files are Timer.cpp and Timer.h.  This seems to confuse Slickedit.

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Auto-complete files recently added to the workspace (Slickedit 15.0.1.3)
« Reply #3 on: September 23, 2010, 07:11:31 pm »
We're wondering if this is due to preprocessing in the file. When you open the file, look in the Document menu. Do you see an entry that says, "C/C++ Options"? Also, open the Defs tool window. Are all of the symbols defined there?

If the file does contain #if sections, you will need to define the preprocessing values to SlickEdit, otherwise the parser will not handle it correctly. There are instructions for how to do that in the User Guide, under Language Specific Editing > C and C++ > C/C++ Preprocessing.