Author Topic: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)  (Read 5082 times)

tgulick

  • Community Member
  • Posts: 10
  • Hero Points: 0
SlickEdit Version 12.0.3.0

Serial number: VLX826044
Licensed number of users: Single user

Build Date: August 14, 2007
Emulation: GNU Emacs
Hi,

this is a new install of Ubuntu and so may be missing some packages. If I try to do a version control "diff with most up-to-date version" or "history" on a file, Slickedit just hangs and I have to kill it. strace of the process shows it stuck waiting but can't tell on what. Svn command line from a shell works fine to the same repository as well as smartsvn GUI tool.

About half the time, when I start SlickEdit, I get a bunch of pop-ups complaining about DLL's. Next time it happens, I'll note what they say but I don't have the info now.

Previously had FC11 and had no issues but the disk died and so Ubuntu is the new Linux choice. Installation was smooth.


OS: Linux
OS Version: Ubuntu 10.04.1 LTS
Kernel Level: 2.6.32-24-generic
Build Version: #43-Ubuntu SMP Thu Sep 16 14:58:24 UTC 2010
X Server Vendor: The XFree86 Project, Inc

Installation Directory: /opt/slickedit/
Configuration Directory: /home/tgulick/.slickedit/12.0.3/

Hotfixes:
/home/tgulick/.slickedit/12.0.3/hotfixes/hotfix_se1203_cumulative.zip (Revision: 35)

tgulick

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #1 on: September 23, 2010, 06:18:11 pm »
So it's worth noting that the new Ubuntu machine is AMD64 while the FC11 machine was i686

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #2 on: September 23, 2010, 07:00:40 pm »
Any version of SlickEdit before v15.0 is incompatible with Ubuntu 10.04. There are many threads on the forums documenting similar issues. The only solution we can offer is upgrade SlickEdit or use an earlier version of Ubuntu.

David_O

  • Senior Community Member
  • Posts: 152
  • Hero Points: 8
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #3 on: September 23, 2010, 07:03:47 pm »
Unfortunately, only the latest version of SlickEdit (2010) is supported on Ubuntu 10.4.  The fix for the DLL messages that you report is to upgrade to SlickEdit 2010.  I suspect this is also the cause of your subversion problems.

Thank you,

-David-

tgulick

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #4 on: September 23, 2010, 07:14:17 pm »
Thanks for the help. I suspected I was out of mileage on 12.0.3

-tom

tgulick

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #5 on: September 23, 2010, 08:10:45 pm »
I pulled down a trial V15.0 version and installed. I tried a "diff with latest version", after 2 -3 minutes I got a pop-up asking for my svn credentials and after 10 minutes I'm still waiting for something to happen.

strace of vs pid

waitpid(14586, 0xff8b6e8c, WNOHANG)     = 0
gettimeofday({1285272523, 427593}, {240, 0}) = 0
nanosleep({0, 10000000}, NULL)          = 0
select(17, [16], NULL, [16], {0, 0})    = 0 (Timeout)
select(21, [20], NULL, [20], {0, 0})    = 0 (Timeout)
waitpid(14586, 0xff8b6e8c, WNOHANG)     = 0
gettimeofday({1285272523, 438800}, {240, 0}) = 0
nanosleep({0, 10000000}, NULL)          = 0
select(17, [16], NULL, [16], {0, 0})    = 0 (Timeout)
select(21, [20], NULL, [20], {0, 0})    = 0 (Timeout)
waitpid(14586, 0xff8b6e8c, WNOHANG)     = 0
gettimeofday({1285272523, 449034}, {240, 0}) = 0
nanosleep({0, 10000000}, NULL)          = 0
select(17, [16], NULL, [16], {0, 0})    = 0 (Timeout)
select(21, [20], NULL, [20], {0, 0})    = 0 (Timeout)
waitpid(14586, 0xff8b6e8c, WNOHANG)     = 0
gettimeofday({1285272523, 459337}, {240, 0}) = 0

tgulick

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #6 on: September 23, 2010, 09:01:47 pm »
tried a different svn repository and was able to do a successful history of a file.

Still having issues with initial repository but probably not a SE issue

-tom




tgulick

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #7 on: September 24, 2010, 06:39:15 pm »
subversion support works fine for one of my repositories and not for another. No remote files or logs seem to be retrieved ie a "diff with most up to date version" always shows an empty file for the remote version

The only differences are

1. the "good" repos uses http: as the subversion transport, the "bad" one uses the svn://blah transport
2. the good repos has the same username as my linux username, the "bad" one doesn't

I'm prompted for user and password every time for the "bad" repository.

svn version on my machine is 1.6.6

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2440
  • Hero Points: 137
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #8 on: September 24, 2010, 06:53:20 pm »
Just need to be clear, nothing works even after it prompts you?

tgulick

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #9 on: September 24, 2010, 06:59:47 pm »
Hi Dan,

Correct. I get the auth prompt from the svn::// repos, I enter my cred's and after what seems like a long time compared to the FC11 machine I was using with SE 12.0.3 to the same repos, I get the diff screen but the remote file is empty.

The http: repos doesn't prompt me and the response time is similar to my old FC11/SE12.0.3 setup

-tom

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2440
  • Hero Points: 137
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #10 on: September 24, 2010, 07:46:15 pm »
Tom:
I am sorry you are having problems with this.  Can you please do the following:
  • Launch SlickEdit from a console window
  • Go to Macro>Set Macro Variable
  • Choose the variable _CVSDebug, and set the value to 1
  • Run one of the operations that is failing
  • This will generate some output in the console window that you launched the editor from.  Please send that output to me (rather than post it here, please PM it, or send me a PM and I will send you an email address)
Once I have this output I should be able to tell what the problem is.

tgulick

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #11 on: September 27, 2010, 02:01:09 pm »
Have the output..newbie question: What's PM ?

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2440
  • Hero Points: 137
Re: subversion comands hanging with 12.0.3.0 and Ubuntu 10.04 (new install)
« Reply #12 on: September 27, 2010, 02:02:08 pm »
Private message.  If you click on my username anywhere in this thread, you should see an option to send a private message.