Author Topic: Grammar/Spell/whatever checker "stuck on"  (Read 5307 times)

brebey

  • Community Member
  • Posts: 58
  • Hero Points: 2
Grammar/Spell/whatever checker "stuck on"
« on: October 28, 2010, 05:41:11 pm »
I'm  using Core in Eclipse, and there  is some kind of grammar checker or spell checker or something  like  that  turned on in SECore     that is making a terrible   mess of my screen and making things very difficult to read.    I have no idea what it is, and can't see anything in the Options that  seems like  it's causing this. 

How do I turn this  feature off?

Screen shot attached.  The Amber  zig-zag lines all  over the place are the things that I'm trying to turn off.

Thanks!

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Grammar/Spell/whatever checker "stuck on"
« Reply #1 on: October 28, 2010, 07:28:29 pm »
I think those are warnings...from the Java compiler.  If you mouse over the little yellow boxes in the overview ruler to the right of the editor, are there valid warnings that pop up in the tooltips?  If you look at the Problems view down below, are there a bunch of warnings reported for that file?

Go to Window > Preferences > Java > Editor and uncheck "Report problems as you type".  Does that get rid of it?

- Ryan


brebey

  • Community Member
  • Posts: 58
  • Hero Points: 2
Re: Grammar/Spell/whatever checker "stuck on"
« Reply #2 on: October 29, 2010, 03:10:14 pm »
Yea, Ryan, that got rid of it. 

Is there a way, though, to simply  have SE not put the zigzag  lines in there, while leaving the "as you type" warning/error checking enabled,  which puts the warning bars on the overeview ruler?  I'd like to leave the feature on and just turn off the messy zigzag indicators.

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Grammar/Spell/whatever checker "stuck on"
« Reply #3 on: October 29, 2010, 04:08:05 pm »
I don't think so :/...the setting I was hoping would change it is at Window > Preferences > General > Editors > Text Editors > Annotations, and then selecting Warning and unchecking the "Text As" setting.  But this doesn't appear to make any difference for the live errors, only actual build errors.  That could be a bug...I'll look into it some more and see if we can fix that.

- Ryan

brebey

  • Community Member
  • Posts: 58
  • Hero Points: 2
Re: Grammar/Spell/whatever checker "stuck on"
« Reply #4 on: October 29, 2010, 04:21:30 pm »
Thanks, Ryan!  Please inform if you find a way around this problem.