Author Topic: Setting SlickEdit as the OpenWith Default Program in Vista  (Read 3342 times)

ojm37

  • Community Member
  • Posts: 21
  • Hero Points: 0
Setting SlickEdit as the OpenWith Default Program in Vista
« on: December 23, 2010, 06:11:27 pm »
I'm using VS 13.0.0.0 on Windows Vista Business and I'm having the following problem:

When I right-click on a file and select "Open With" / "Choose Default Program", Slick Edit is NOT in the list of programs AND when I browse to it, I cannot select it.  (I can browse to it and click on vs.exe, but it never shows up in the "Open With" dialog so that I can choose it as the default program).

Anyone know how I can get Vista to do this?

TIA,
Owen

Graeme

  • Senior Community Member
  • Posts: 2389
  • Hero Points: 314
Re: Setting SlickEdit as the OpenWith Default Program in Vista
« Reply #1 on: December 24, 2010, 09:50:47 am »
You could try reading this  - google for "open with" vista
http://www.vistax64.com/tutorials/126340-open-add-program.html

It's not likely to be a slickedit specific problem - so maybe try a vista forum if you still can't get it to work.

Scott H

  • Senior Community Member
  • Posts: 240
  • Hero Points: 9
Re: Setting SlickEdit as the OpenWith Default Program in Vista
« Reply #2 on: January 04, 2011, 02:02:00 pm »
Hmm... I haven't had this problem running Vista.  When you browse to SlickEdit and select it, do you also check the box to "Always use the selected program to open this kind of file"?  If you check that and select vs.exe, I think that will keep SlickEdit as an option for all future uses of the "Open With" dialog (it will put it in the "Other Programs" group).

gtaylor20

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: Setting SlickEdit as the OpenWith Default Program in Vista
« Reply #3 on: January 17, 2011, 09:46:22 pm »
I just had this problem after installing the latest update for v15 on a Windows 7 system.  After some googling, I found that it is a registry problem.  Basically, I had to change the directory where the new update resides (changed from SlickEditV15.0.0 to SlickEditV15.0.1).  Here are the appropriate passages where I found the solution:

The program that you're pointing to isn't registered correctly.

In regedit: Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name.
Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable, hit okay and then try and reassociate the file type as you normally would.

Actually this most often happens when you have an earlier version of the program and you upgrade.  Like from Photoshop 7 to Photoshop CS3.  The uninstaller does not remove the registry keys like it should.


Maybe someone at SlickEdit will take notice of this.  :)

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Setting SlickEdit as the OpenWith Default Program in Vista
« Reply #4 on: January 18, 2011, 03:31:56 pm »
I just ran some tests, and it looks to me like that value is set based on the last installer that is run. So, I initially had it set to v16.0.0 (not available to the general public, yet). Then I installed v15.0.1 and it changed to that version. Then I installed v16.0.0 again and it changed back.

So, I'm not sure how this problem occurred. We don't really upgrade SlickEdit. Each version is a complete install of its own. I typically copy install directories and rename them to keep multiple versions around. Have you done something like that? Could that be how this arose?

gtaylor20

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: Setting SlickEdit as the OpenWith Default Program in Vista
« Reply #5 on: January 18, 2011, 06:38:06 pm »
All I did was execute the file "se_15000103_win_full.msi".  I don't recall taking any choices but the defaults.  I'm not really going to worry about it any more, but I just wanted to share my solution in case it ever happens to anyone else.  Thanks for looking into it.

jimlangrunner

  • Senior Community Member
  • Posts: 360
  • Hero Points: 31
  • Jim Lang - always a student.
Re: Setting SlickEdit as the OpenWith Default Program in Vista
« Reply #6 on: January 18, 2011, 11:55:50 pm »
Just as an aside - if you turn off UAC and run an installer, it seems to work okay, but doesn't always get everything.  Perhaps you weren't running as administrator when you did the install? 

And to clarify, even if you're an administrator, you have to "Run As" administrator for all of the installer functionality to work correctly.