Author Topic: general options->select styles greyed out  (Read 6691 times)

quack

  • Community Member
  • Posts: 18
  • Hero Points: 1
general options->select styles greyed out
« on: July 05, 2006, 08:48:22 pm »
Hi, all.
I've only used this editor for a short bit and am trying to get it setup like my ol trusty editor. When I select Tools->"general options"->"select styles" then the user defined radio option is greyed out along with the styles check boxes. Anyone have any ideas on how to ungrey these out?

Thanks
quack

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 337
  • Hero Points: 26
Re: general options->select styles greyed out
« Reply #1 on: July 05, 2006, 09:24:48 pm »
You can change these options by using internal SlickEdit variables.  The reason that these are greyed out is because they are specific to certain emulations and shouldn't be changed unless you are familiar with them.  What option would you like to change and what emulation are you running?  You can check your emulation by going to Tools > Options > Emulation.

quack

  • Community Member
  • Posts: 18
  • Hero Points: 1
Re: general options->select styles greyed out
« Reply #2 on: July 06, 2006, 02:40:20 pm »
thanks, i'm running brief emulation but I would like "auto deselect (i.e when cursor moves)" to be disabled. This option should probably work with brief ok... i hope.

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 337
  • Hero Points: 26
Re: general options->select styles greyed out
« Reply #3 on: July 07, 2006, 04:03:35 pm »
If you go to Macro > Set Macro Variable > enter def_persistent_select as the Variable name and set the value to 'Y' (without the single quotes) this will get you what you are expecting.  This will however change other cases where the selection is not deselected or replaced/deleted.


JakeMontgomery

  • Community Member
  • Posts: 79
  • Hero Points: 8
Re: general options->select styles greyed out
« Reply #4 on: July 19, 2006, 04:04:02 pm »
That all well and good, but is there any way to get the "User Defined" radio button to be available?  The documentation shows it as available
(I would like to change "delete selection before insert")

Thanks much.