Author Topic: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"  (Read 16505 times)

mwilkins

  • Community Member
  • Posts: 28
  • Hero Points: 1
I am looking at purchasing the core plugin for use with the QNX environment , but I cannot update to the lastest version of the development IDE , as I need the older version of the QNX suite for compatibility with some custom hardware.
When I try and install the Trial of Slickedit core, I get an error "requires plugging "org.eclipse.php.debug.core"". Is there anyway I can install this extra plug in, and if so, where from? I have managed to get an older version of Slickedit core 3.3.1 from a thread on this forum which points to https://customer.slickedit.com/update/secore/ ,which installs fine, but the trial licence does not work for this older version, it is asking for a number, not a licence file. Any help getting this going would be great, as I hate going back to the eclipse editor ( we used Slickedit 2010 at my old position), and am keen to get the plug in going, but obviously don't want to purchase without knowing it is going to work.

Thank you

mwilkins

  • Community Member
  • Posts: 28
  • Hero Points: 1
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #1 on: February 25, 2011, 11:58:59 am »
To be more precise , it says

PHP (SlickEdit Integration with PDT) (3.6.1) requires plug-in "org.eclipse.php.debug.core".


Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #2 on: February 25, 2011, 04:14:30 pm »
What version of Eclipse is this QNX IDE based on?  Is it Eclipse 3.3 or earlier?

If this is the case ( man, that is old :( ) then I will have to figure out how to get you a trial license key, because as you've already discovered, SlickEdit Core 3.3.1 and earlier used a different licensing mechanism.

If this is not the case, you shouldn't be getting that error from the installer...I'll have to figure that out.

- Ryan

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #3 on: February 25, 2011, 04:30:16 pm »
I think I figured out something that should allow you to use the trial license file you have with the 3.3.1 product, even though Core 3.3.1 expects a key not a file.  Close Eclipse and create an environment variable in Windows called VSFLEX_LICENSE_FILE and set the value to the full path to your trial license file that you downloaded, ie. C:\path\to\license\slickedit.lic.

Now start Eclipse...does this work?

- Ryan

mwilkins

  • Community Member
  • Posts: 28
  • Hero Points: 1
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #4 on: February 25, 2011, 05:45:36 pm »
I think I figured out something that should allow you to use the trial license file you have with the 3.3.1 product, even though Core 3.3.1 expects a key not a file.  Close Eclipse and create an environment variable in Windows called VSFLEX_LICENSE_FILE and set the value to the full path to your trial license file that you downloaded, ie. C:\path\to\license\slickedit.lic.

Now start Eclipse...does this work?

- Ryan

Thanks Ryan, yes it is very old it is eclipse
Release 3.2.2
Last revised January 19, 2007.

So is this the newest version of Slickedit core that will work with this version of eclipse? or is there a version that would be better than this one between the  3.3.1 and 3.6.1. releases tha I could try?

The licencing file worked great with the Environment variable you suggested. So if this is the best that I can use, can I get a reduction in the lincencing fee as the program is about 4 years old, or is there a licencing option that is not a yearly subscription that would suit me better for the older version?

PM me if needed,

Thanks

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #5 on: February 25, 2011, 07:20:07 pm »
SlickEdit Core 3.3.1 only officially supports Eclipse 3.3.x :/.  But...that is probably the closest you will get.

On the other hand, since you are trying to use our plugin in such an old version of Eclipse, you might want to just go ahead and try the latest version of our plugin (3.6.1) and see if it works.  It is far superior to our 3.3.1 version.  If you do want to try this, as you've already encountered, you will have some trouble installing because Eclipse has changed the installation mechanism so much between 3.2 and 3.6...what you will probably have to do is install the JDT, CDT, and PDT plugins even though you might not need them.  The reason for this is that we have 3 plugins which are dependent on these plugins (JDT, CDT, and PDT).  We we mark them as "optional" for install, but I don't think the Eclipse 3.2-based plugin installation mechanism can even recognize that they are optional, so it's trying to force you to install them...and thus, complaining that "org.eclipse.php.debug.core" isn't there.

So if you have the time and feel like trying it out, and don't mind the wasted space of installing plugins that you don't need, give it a shot.  If it works, you'll probably be really happy that you tried it.  I can mess around in Eclipse 3.2 and see if I can get our 3.6.1 plugin to install without installing CDT/JDT/PDT if I have some time.

I'm glad the environment variable trick works...but I don't think you are going to get a reduction in cost just for using an older version :).  Feel free to contact our sales department and ask, though: sales@slickedit.com.

- Ryan

mwilkins

  • Community Member
  • Posts: 28
  • Hero Points: 1
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #6 on: February 25, 2011, 10:07:51 pm »
Thanks Ryan, if you could try and get 3.6.1 going with 3.2 that would be great.
Where can I get the 3 plugins you mention from , the JDT, CDT, and PDT plugins? What exactly are they? so I can have a go myself, because like you say, your new plugin is more superior, and if I am paying full price for  for it , obviously I would like the new version, not the 3 year old version.

thanks

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #7 on: February 25, 2011, 10:51:40 pm »
Those are the development toolkits for Java, C, and PHP...respectively...they are written by groups at Eclipse.  You should be able to find and install them through the update manager in Eclipse...they should be available on some eclipse.org site that you can access through the update manager.  I just don't know how to tell you to find them exactly because I don't have Eclipse 3.2 installed on my system right now...but I am working on that.

- Ryan

mwilkins

  • Community Member
  • Posts: 28
  • Hero Points: 1
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #8 on: February 26, 2011, 05:46:43 pm »
Thanks Ryan,
I had a go at trying to download the plugins, but the only versions I could find were already embedded into a copy of eclipse. I tried copying their components from the plugin and feature folders , and placing into the plugin and feature folders on my copy, but it still complains that "org.eclipse.php.debug.core""is not present, so I must need it to go through some proper install process. Does anyone know where and how I can install these plugins? Its strange, because if I try and add Slickedit core 3.6.1 to the newer QNX suite ( which I cannot use) , it installs fine , even though "org.eclipse.php.debug.core"" is not present ? How come that works then without it?

If you could get it working Ryan, I would be extremely grateful


mwilkins

  • Community Member
  • Posts: 28
  • Hero Points: 1
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #9 on: February 26, 2011, 10:22:36 pm »
I have tried several sources for PDT, but I have problems with them all

http://download.eclipse.org/releases/helios/

just fails at 6% when asking for an update

http://downloads.zend.com/pdt/

wants Zend Debugger Feature (5.2.15.v20081217) requires feature "org.eclipse.php_feature (1.0.2)", or equivalent.

http://download.eclipse.org/tools/php/updates/

complains PDT Feature (1.0.5.v20081126-1856) requires feature "org.eclipse.wst (3.0.0)", or compatible.

I just don't seem to be getting anywhere, I have been trying for hours today. Are these the right sites? Am I doing something wrong?


Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #10 on: February 27, 2011, 08:05:44 pm »
I tried two things...and neither worked :/.  I'll tell you what I tried in case you are curious, or want to try for yourself.  But from what I can see, I can't get SlickEdit Core 3.6.1 to work in Eclipse 3.2.x.

The first thing I tried was just to bypass the "optional" features which have the dependencies on the PDT/CDT/JDT plugins by manually installing SlickEdit Core.  I grabbed the archive file for offline installation (which is available at http://www.slickedit.com/trial/slickedit-core via the download link at the bottom of the page), and unzipped it.  Then I unzipped all the required plugins and features jar files into their respective folders.  For example, I unzipped com.slickedit.core_3.6.1.jar into com.slickedit.core_3.6.1/.  I did this for:

  • plugins/com.slickedit.core
  • plugins/com.slickedit.eclipse.plugin
  • plugins/com.slickedit.help
  • plugins/com.slickedit.windows.libs
  • features/com.slickedit.features

Then I dragged/dropped the plugins directories that I just extracted into the ECLIPSE3.2/plugins directory, and the features directory into the ECLIPSE3.2/features directory...and started Eclipse.  I thought this would work, but then when I tried to activate SlickEdit Core by going to Help > About SlickEdit Core, it wouldn't activate :/.  There was no error thrown but I checked the .log file for the workspace and I saw an exception that didn't make sense.  If Core 3.6.1 was compatible with Eclipse 3.2-based software I would expect this to work.

My second attempt was to install CDT, JDT, and PDT in order to use the Eclipse installation mechanism at Help > Software Updates > Find and Install to installed SlickEdit Core.  JDT came with the version of Eclipse 3.2 I downloaded, and CDT was easily downloaded/installed.  But I couldn't get PDT to install...I kept getting the same exception installing the same required plugin for PDT.  Here are the directions I found for installing PDT in Eclipse 3.2.x: http://wiki.eclipse.org/PDT/Installation#Eclipse_3.2_.2F_Callisto_.2F_PDT_0.7 .  You can see if you can get that to work, and the try installing Core 3.6.1.

Sorry I don't have better news,

Ryan


mwilkins

  • Community Member
  • Posts: 28
  • Hero Points: 1
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #11 on: February 27, 2011, 10:12:06 pm »
Thanks Ryan for all your help. I Tried your method 1 as above, and all the slickedit menu items appear, but nothing happens when I select them. I assume this is what you have seen.

I cannot get the second method you outline to install the PDT, as no matter what I do, there is always something else that is missing first that needs to be installed.

If you do manage to make any headway and get any help on the exception you are seeing, please get back to me, and this week I will try testing the 3.3.1 trial with what I have got. I have contacted your sales department to see if they can do a reduction for the 3 year old product as you suggested for when the trial expires.

I can't thank you enough for getting me going at least for now, you are a star!


Cheers

Martin

mwilkins

  • Community Member
  • Posts: 28
  • Hero Points: 1
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #12 on: February 27, 2011, 10:13:18 pm »
oh and are there any hotfixes for 3.3.1 that may be handy? and if so, where could I obtain them from?...thanks

mwilkins

  • Community Member
  • Posts: 28
  • Hero Points: 1
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #13 on: February 28, 2011, 11:20:52 am »
Hi Ryan,
I have started using 3.3.1 today, but am finding there seems to be a problem with the Preview window. It seems to work OK for a bit, but then after a while, if I select a variable or a method, the Preview window does not update with the relevent information.... until I drop the cursor in the Preview Window itself... its like it has stopped updating itself. I'm sure if this was the case there would have been a hotfix for it, or it there anything else I can do to sort it? I'm sure a couple of years ago Slickedit 2009 or some version like that did the same and it was sorted later.

Also ( again after a while of using it) the information from the tagging seems slow too  I have tried upping the size of the tag cache nand buffer size to twice their original size, but it seems to make no difference....

I am using a Pentium 4 3.0 GHz with 1.5 g of ram Windows XP, which I am asuming is a good spec for an old piece of software like this


......Oh for a working 3.6.1



Sorry I have just come back to edit this post as I have found out more about the Preview Problem

The Preview works fine if you only select items in say one cpp file.... as soon as you then go to another cpp file, it starts messing arround ( ie you now have to put the cursor in the Preview window to refresh.... or as below, it locks up completely)
Sometimes the preview window also locks up after a while too. At this point all I can do is close the preview window, and open it again to get it slightly working again. This is one of the features of Slickedit which I use the most, one of the main reasons for wanting to purchase it. Is there a quick way to close and open the Preview window, to save having to go to the Window->Show View->Other to open and close the window? I tried to bind both the activate Preview and Toggle Preview commands to keys, but neither of them seem to work, or do what I want.

Any suggestions?
« Last Edit: February 28, 2011, 12:00:16 pm by mwilkins »

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: older version of Eclipse requires plug-in "org.eclipse.php.debug.core"
« Reply #14 on: February 28, 2011, 03:35:13 pm »
I looked around for hotfixes on our share drive and also on these forums and didn't find any...sorry :(.  I was really hoping to find something that would affect the Preview window b/c, as you've discovered, the Preview window in Core 3.3.1 seems really buggy.  I've now seen this for myself.  If I can get some time to see if I can figure this one out, I'll let you know...but I can't make any promises since you are working in an unsupported setup.

There is no command for quickly activating the Preview window in that version of Core.

I know...it sucks that QNX is on such an old Eclipse platform...if it was just on even 3.4 we wouldn't have to deal with this :/.  We deal with a lot of Eclipse based IDEs (RDz, Adobe Flex, etc.) and they all are on 3.4 or later...

- Ryan