Author Topic: Difficulty applying hotfix 19 (DateTime bug)  (Read 1675 times)

jimlangrunner

  • Senior Community Member
  • Posts: 358
  • Hero Points: 30
  • Jim Lang - always a student.
Difficulty applying hotfix 19 (DateTime bug)
« on: March 02, 2011, 06:32:09 pm »
When applying the hotfix, the message box explaining the contents popped as too tall to display, and included a scrollbar.  I was able to scroll down to read a LOT of text, but could not get to the OK or cancel buttons.  I couldn't even use keyboard shortcuts to get it.  I do not know why.

I rotated my primary display from landscape to portrait (1920 x 1080) and was able to get to the OK button that way.  I'm not sure I've ever seen something like this before.  The attached screenshot is my primary display.  2nd display is 1280 x 1024 screen to the right. 

system info:
SlickEdit Version 15.0.1.3

Serial number: WB830477
Licensed number of users: Single user
License file: C:\ProgramData\slickedit\15\slickedit.lic

Build Date: August 04, 2010
Emulation: Visual Studio

OS: Windows 7 x64
OS Version: 6.01.7600 
Memory: 67% Load, 2795MB/4123MB Physical, 263MB/2097MB Virtual
Shell Info: C:\Windows\system32\cmd.exe /q
Screen Size: 1920 x 1080

Project Type: Other
Language: No file open

Installation Directory: C:\Program Files (x86)\SlickEditV15.0.1\ (non-removable drive,NTFS,65997MB free)
Configuration Directory: C:\Users\jlang\Documents\My SlickEdit Config\15.0.1\ (non-removable drive,NTFS,65997MB free)

Hotfixes:
C:\Users\jlang\Documents\My SlickEdit Config\15.0.1\hotfixes\hotfix_loader_se15013_3(2).zip (Revision: 3)
C:\Users\jlang\Documents\My SlickEdit Config\15.0.1\hotfixes\hotfix_loader_se15013_3.zip (Revision: 3)
C:\Users\jlang\Documents\My SlickEdit Config\15.0.1\hotfixes\hotfix_se1501_11_cumulative.zip (Revision: 11)
C:\Users\jlang\Documents\My SlickEdit Config\15.0.1\hotfixes\hotfix_se1501_18_cumulative.zip (Revision: 18)
C:\Users\jlang\Documents\My SlickEdit Config\15.0.1\hotfixes\hotfix_se1501_19_cumulative.zip (Revision: 19)
C:\Users\jlang\Documents\My SlickEdit Config\15.0.1\hotfixes\hotfix_se1501_3_cumulative.zip (Revision: 3)



Thanks,
Jim

Phil Barila

  • Senior Community Member
  • Posts: 746
  • Hero Points: 61
Re: Difficulty applying hotfix 19 (DateTime bug)
« Reply #1 on: March 02, 2011, 06:35:28 pm »
Just reapply the hotfixloader hotfix.

jimlangrunner

  • Senior Community Member
  • Posts: 358
  • Hero Points: 30
  • Jim Lang - always a student.
Re: Difficulty applying hotfix 19 (DateTime bug)
« Reply #2 on: March 02, 2011, 06:49:03 pm »
Thanks - that did it.  Didn't occur to me to try that again - that's the 3rd time I've applied that particular hotfix..

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Difficulty applying hotfix 19 (DateTime bug)
« Reply #3 on: March 02, 2011, 07:07:52 pm »
Are you doing this in a different config? Hot fixes are stored in your state file, which is stored in your config. They don't actually get applied against the macro files that we ship. So, hot fixes have to be applied to every config that you use. If you delete a config or point to a different one, you will have to reapply the hotfix. In this case, that includes the loader.

There is some good documentation in the User Guide about setting up a directory to automatically load hot fixes. I use this since it eases the process of keeping my instances up to date.  See Introduction > Installation > Upgrading SlickEdit > Applying Hot Fixes > Automatically Installing Hot Fixes.

jimlangrunner

  • Senior Community Member
  • Posts: 358
  • Hero Points: 30
  • Jim Lang - always a student.
Re: Difficulty applying hotfix 19 (DateTime bug)
« Reply #4 on: March 02, 2011, 07:15:09 pm »
That's probably it - I did delete the State file while trying to manually fix the datetime issue - I probably didn't put it back right. 

I don't generally have trouble with applying hotfixes - they generally just work (and I should have figured that out in the first place)

thanks